xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Custom Query (2683 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (1 - 3 of 2683)

1 2 3 4 5 6 7 8 9 10 11
Ticket Resolution Summary Owner Reporter
#3006 fixed python2-lz4 in centos 7.9 Caleb Khor Caleb Khor
Description

I've noticed the following for the packaging for Centos 7.x versions of xpra:

  • Centos 7.6: lz4 and python2-lz4 are from xpra. Latest xpra version is 3.0.13.
  • Centos 7.7: lz4 and python2-lz4 are from xpra. Latest xpra version is 3.0.9
  • Centos 7.8: python2-lz4 is from xpra. lz4 is absent. latest xpra version is 3.0.13
  • Centos 7.9: python2-lz4 and lz4 are both absent. latest xpra version is 3.0.13

It seems that the version of python2-lz4 (2.2.1) is critical for xpra to work, not so for lz4, as it can be swapped with the system version.

While 3.0.13 largely worked on Centos 7.9, there is a bug when xpra shadow is invoked (both via the command line and gui), the xpra session just crashes after a while during launch. It just terminates itself without any reason, and UNKNOWN sessions were created (which of course cleaned up later). It seems that restoring python2-lz4 (2.2.1) (obtained from the other distros) makes it work again.

It is in my view that for the Centos 7.9 distribution, perhaps python2-lz4 should be included?

#3004 invalid xpra cannot be built TCH68k TCH68k
Description

Hello,

I am trying to build xpra, but it keeps failing at the final linking with this message:

/usr/bin/ld: /usr/local/lib/libx264.a(cabac-a.o): relocation R_X86_64_PC32 against symbol `x264_cabac_range_lps' can not be used when making a shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value
collect2: error: ld returned 1 exit status
error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

The command line was ./setup.py --without-strict build. I tried options --without-dec_avcodec2, --without-csc_swscale, --without-enc_ffmpeg and even --with-PIC, though i saw in the source that it is the default. Tried them separately, together, whatever. It keeps failing.

I did not set any milestone or version, because i've tried it with 2.0.3, 2.5.3 and 3.0.13 and all of them did this. I need at least xpra 2.0, so i did not tried below and 4.0 refused to compile by telling Python 3.6 is the minimum (it is installed), so i did not try above either. Most probably all versions are affected, or at least all of them from 2.0.0 to 3.0.13.

The build switches and "diagnostics" dumped on the terminal at the start of the build:

Xpra version 2.0.3
found pkg-config version: 0.29
build switches:
* enc_x264             : Y
* enc_x265             : Y
* enc_ffmpeg           : Y
* nvenc7               : N
* cuda_rebuild         : Y
* vpx                  : Y
* pillow               : Y
* jpeg                 : N
* v4l2                 : Y
* dec_avcodec2         : Y
* csc_swscale          : Y
* csc_libyuv           : N
* bencode              : Y
* cython_bencode       : Y
* vsock                : Y
* mdns                 : Y
* clipboard            : Y
* server               : Y
* client               : Y
* dbus                 : Y
* x11                  : Y
* gtk_x11              : Y
* service              : Y
* gtk2                 : Y
* gtk3                 : N
* html5                : Y
* minify               : Y
* pam                  : Y
* sound                : Y
* opengl               : Y
* printing             : Y
* webcam               : Y
* rebuild              : Y
* annotate             : Y
* warn                 : Y
* strict               : N
* shadow               : Y
* proxy                : Y
* debug                : N
* PIC                  : Y
* Xdummy               : Auto
* Xdummy_wrapper       : Auto
* verbose              : N
* tests                : N
* bundle_tests         : N
error running (['uglifyjs', '--version'],),{'stderr': -1, 'stdout': -1}: [Errno 2] No such file or directory
Warning: uglifyjs failed and return -1
Warning: yuicompressor module not found, cannot minify
'nvcc --version' failed with return code 127
stderr: None
updated ./xpra/build_info.py with:
* BUILD_BIT            = 64bit
* BUILD_CPU            = AMD FX(tm)-8350 Eight-Core Processor
* BUILD_DATE           = 2021-01-17
* BUILD_MACHINE        = x86_64
* BUILD_OS             = Linux Devuan 2.1 ascii
* BUILD_TIME           = 20:43
* BUILT_BY             = root
* BUILT_ON             = Csabi
* COMPILER_VERSION     = gcc (Debian 7.3.0-1~mx17+1) 7.3.0
* CYTHON_VERSION       = 0.25.2
* LINKER_VERSION       = GNU ld (GNU Binutils for Debian) 2.28
* PYTHON_VERSION       = 2.7.13
* RELEASE_BUILD        = True
* lib_pygobject        = 2.28.6
* lib_pygtk            = 2.24.0
* lib_vpx              = 1.6.1
* lib_x11              = 1.6.4
* lib_x264             = 0.142.x
* lib_x265             = 0.0
* lib_xcomposite       = 0.4.4
* lib_xdamage          = 1.1.4
* lib_xext             = 1.3.3
* lib_xfixes           = 5.0.3
* lib_xkbfile          = 1.0.9
* lib_xrandr           = 1.5.1
* lib_xtst             = 1.2.3
found gcc version: 7.3.0
#2999 fixed after xpra-server upgrade it fails to start tomuxi tomuxi
Description

With default configuration, after upgrading server from 3.0.12-10.20201007r27627xpra1.el7_8.x86_64 to 3.0.13-10.r28292xpra1.el7_9.x86_64 it fails to start with error OSError: [Errno 13] Permission denied

with previously working command line

xpra start :22 --no-html --no-file-transfer --no-microphone --no-speaker --start=terminator
2021-01-11 09:58:07,134 cannot access python uinput module:
2021-01-11 09:58:07,134  No module named uinput
xpra main error:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/scripts/main.py", line 117, in main
    return run_mode(script_file, err, options, args, mode, defaults)
  File "/usr/lib64/python2.7/site-packages/xpra/scripts/main.py", line 451, in run_mode
    return run_server(error_cb, options, mode, script_file, args, current_display)
  File "/usr/lib64/python2.7/site-packages/xpra/scripts/server.py", line 340, in run_server
    return do_run_server(error_cb, opts, mode, xpra_file, extra_args, desktop_display)
  File "/usr/lib64/python2.7/site-packages/xpra/scripts/server.py", line 643, in do_run_server
    uid, gid, username, xauth_data, uinput_uuid)
  File "/usr/lib64/python2.7/site-packages/xpra/x11/vfb_util.py", line 293, in start_Xvfb
    stdin=PIPE, preexec_fn=preexec)
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1327, in _execute_child
    raise child_exception
OSError: [Errno 13] Permission denied
1 2 3 4 5 6 7 8 9 10 11
Note: See TracQuery for help on using queries.