xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Custom Query (2683 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (4 - 6 of 2683)

1 2 3 4 5 6 7 8 9 10 11 12
Ticket Resolution Summary Owner Reporter
#459 fixed Null character gets added to the end of clipboard contents while copying from MS Windows Antoine Martin AndrewZ
Description

Both client and server versions are 0.10.9, as indicated by 'About' window and 'xpra --version'.

So, when I do, for example, Win+R -> type 'notepad' -> Ctrl+A -> Ctrl+C, then on my virtualboxes' Ubuntu 13.10 putty command prompt execute

$ xclip -o -selection clipboard | cat -v

, I get

notepad^@

which seems to me to be the case of off-by-one-error. So, I'm no expert in X protocol, but if saving clipboard contents requires putting length of the contents, could you please just decrement it by one?

#460 needinfo Xpra win32 client 0.11.0 r4773 not working with 0.11.0 server - plink running, no tray icon, no windows shown Antoine Martin AndrewZ
Description

Cannot provide with more info right now, just have to say that if run from command line (Xpra_cmd.exe) it works!

#2247 worksforme Second session start fails Anthony Stone Anthony Stone
Description

With both client and server newly restarted, the command

xpra start ssh/whirligig --start="gnome-terminal --window-with-profile=Blue" --start=emacs &

starts up normally with terminal and emacs windows as expected. The command

xpra stop ssh/whirligig

appears to close the session normally.

However, repeating the same xpra start command now produces only the X frame of a terminal window on the client, with nothing inside it except a view of the display background. It does not respond to key presses or mouse clicks. No error messages appear. There seems to be an active connection between client and server. The only way to recover seems to be to reboot at least the client and maybe the server too.

Server is Ubuntu 18.04, xpra version v2.5-r22135 Client is Ubuntu 16.04, xpra version v2.5-r22149

The log file contains

2019-04-02 14:33:23,931 cannot access python uinput module:
2019-04-02 14:33:23,931  No module named uinput
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Failed to rename log file "/run/user/1013/xpra/Xorg.S3555.log" to "/run/user/1013/xpra/Xorg.S3555.log": No such file or directory

X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-138-generic x86_64 Ubuntu
Current Operating System: Linux whirligig 4.15.0-46-generic #49-Ubuntu SMP Wed Feb 6 09:33:07 UTC 2019 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-46-generic root=UUID=9dce415d-62a7-423d-9e8b-7547ab58868b ro net.ifnames=0 biosdevname=0 quiet splash vt.handoff=1
Build Date: 25 October 2018  04:11:27PM
xorg-server 2:1.19.6-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.34.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/run/user/1013/xpra/Xorg.S3555.log", Time: Tue Apr  2 14:33:23 2019
(++) Using config file: "/etc/xpra/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
2019-04-02 14:33:26,794 created unix domain socket: /run/user/1013/xpra/whirligig-2
2019-04-02 14:33:26,794 created unix domain socket: /run/xpra/whirligig-2
2019-04-02 14:33:26,840 pointer device emulation using XTest
2019-04-02 14:33:26,847 serving html content from: /usr/share/xpra/www
2019-04-02 14:33:27,596  OpenGL is supported on display ':2'
2019-04-02 14:33:27,596  using 'llvmpipe (LLVM 7.0, 256 bits)' renderer
2019-04-02 14:33:27,627 D-Bus notification forwarding is available
2019-04-02 14:33:27,706 Warning: webcam forwarding is disabled
2019-04-02 14:33:27,706  the virtual video directory '/sys/devices/virtual/video4linux' was not found
2019-04-02 14:33:27,706  make sure that the 'v4l2loopback' kernel module is installed and loaded
2019-04-02 14:33:27,706 found 0 virtual video devices for webcam forwarding
2019-04-02 14:33:27,712 pulseaudio server started with pid 3652
2019-04-02 14:33:27,712  private server socket path:
2019-04-02 14:33:27,712  '/run/user/1013/xpra/pulse-2/pulse/native'
2019-04-02 14:33:28,373 GStreamer version 1.14.1 for Python 2.7.15 64-bit
2019-04-02 14:33:28,392 xpra GTK2 X11 version 2.5-r22135 64-bit
2019-04-02 14:33:28,392  uid=1013 (ajs1), gid=1013 (ajs1-group)
2019-04-02 14:33:28,392  running with pid 3572 on Linux Ubuntu 18.04 bionic
2019-04-02 14:33:28,392  connected to X11 display :2 with 24 bit colors
2019-04-02 14:33:28,461 failed to connect to avahi's dbus interface: org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.freedesktop.Avahi.service not found.
2019-04-02 14:33:28,461  to avoid this warning, disable mdns support 
2019-04-02 14:33:28,461  using the 'mdns=no' option
2019-04-02 14:33:28,461 xpra is ready.
2019-04-02 14:33:29,295 New unix-domain connection received on /run/xpra/whirligig-2
2019-04-02 14:33:29,462 New unix-domain connection received on /run/user/1013/xpra/whirligig-2
2019-04-02 14:33:29,463 New unix-domain connection received on /run/xpra/whirligig-2
2019-04-02 14:33:29,618 New unix-domain connection received on /run/xpra/whirligig-2
2019-04-02 14:33:29,620 Handshake complete; enabling connection
2019-04-02 14:33:29,735  automatic picture encoding enabled, also available:
2019-04-02 14:33:29,735   png, png/P, png/L, webp, rgb24, rgb32, jpeg
2019-04-02 14:33:29,735 Python/GTK2 Linux Ubuntu 16.04 xenial x11 client version 2.5-r22149 64-bit
2019-04-02 14:33:29,735  connected from 'Redwing' as 'ajs1' - 'Anthony Stone'
2019-04-02 14:33:29,801 setting key repeat rate from client: 500ms delay / 30ms interval
2019-04-02 14:33:29,802 setting keymap: rules=evdev, model=hpi6, layout=gb,us
2019-04-02 14:33:29,814 setting keyboard layout to 'gb,us'
2019-04-02 14:33:29,831 waiting for video encoders initialization
2019-04-02 14:33:30,397 printer forwarding enabled using postscript and pdf
2019-04-02 14:33:30,403 15.5GB of system memory
2019-04-02 14:33:30,445  client root window size is 1920x1080 with 1 display:
2019-04-02 14:33:30,446   :0.0 (508x285 mm - DPI: 96x96) workarea: 1867x1056 at 53x24
2019-04-02 14:33:30,446     monitor 2 (521x293 mm - DPI: 93x93)
2019-04-02 14:33:30,479 server virtual display now set to 1920x1080
2019-04-02 14:33:30,488 DPI set to 96 x 96
2019-04-02 14:33:30,567 client @10.738 Xpra GTK2 X11 server version 2.5-r22135 64-bit
2019-04-02 14:33:30,567 client @10.739  running on Linux Ubuntu 18.04 bionic
Gtk-Message: 14:33:30.589: Failed to load module "canberra-gtk-module"
2019-04-02 14:33:30,665 client @10.843 server does not support xi input devices
2019-04-02 14:33:30,666 client @10.843  server uses: xtest
2019-04-02 14:52:01,232 Warning: not adding duplicate printer 'Canon_MP620_series__00_00_85_e9_76_6f_'
1 2 3 4 5 6 7 8 9 10 11 12
Note: See TracQuery for help on using queries.