xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Custom Query (2683 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (76 - 78 of 2683)

Ticket Resolution Summary Owner Reporter
#1472 fixed No /usr/share/xpra/cuda in Ubuntu Packages B B
Description

Hi,

great work in xpra!! In the Ubuntu packages im missing the whole /usr/share/xpra/cuda dir.

Error:

2017-03-24 15:04:42,409 Error: failed to load module from buffer for 'BGRA_to_NV12'
2017-03-24 15:04:42,593  cannot load nvenc7 (nvenc encoder): Encoder missing from xpra.codecs.nvenc7.encoder
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/xpra/codecs/loader.py", line 67, in codec_import_check
    init_module()
  File "xpra/codecs/nvenc7/encoder.pyx", line 2622, in xpra.codecs.nvenc7.encoder.init_module (xpra/codecs/nvenc7/encoder.c:33572)
  File "xpra/codecs/nvenc7/encoder.pyx", line 1481, in xpra.codecs.nvenc7.encoder.Encoder.init_context (xpra/codecs/nvenc7/encoder.c:11579)
  File "xpra/codecs/nvenc7/encoder.pyx", line 1469, in xpra.codecs.nvenc7.encoder.Encoder.init_context (xpra/codecs/nvenc7/encoder.c:11325)
  File "xpra/codecs/nvenc7/encoder.pyx", line 1572, in xpra.codecs.nvenc7.encoder.Encoder.init_cuda_kernel (xpra/codecs/nvenc7/encoder.c:13914)
AssertionError: failed to load BGRA_to_NV12 for device 0

Greets from Germany

#1476 fixed proxy control socket permission error B B
Description

Hi,

im trying to setup a working xpra proxy server. I followed https://xpra.org/trac/wiki/ProxyServer

im on 3x ubuntu 16.04 (proxyhost+targethost in docker containers and the client is a physical machine)

Xpra Version on all machines: v2.1-r15427

on the proxy server i start the proxy with:

xpra proxy :100 --bind-tcp=0.0.0.0:10050 --auth=multifile:filename=/xpra-auth --no-daemon -d all
cat xpra-auth
john|secretpassword|1000|1000|tcp:172.17.0.3:10000|EXAMPLE_ENV=VALUE|compression=0
cat /etc/passwd
....
nvidia-persistenced:x:106:109:NVIDIA Persistence Daemon,,,:/:/sbin/nologin
john:x:1000:1000:,,,:/home/john:/bin/bash

on the targethost

xpra start :11 --bind-tcp=0.0.0.0:10000 --no-clipboard --no-pulseaudio --start-child="glxgears" --exit-with-child --no-printing --no-speaker --no-cursors --dbus-control=no --dbus-proxy=no --use-display --no-daemon

and on the client host

xpra attach --username=john --password-file=/password.txt tcp:i31forhlr4:10050
cat password.txt 
secretpassword

on the proxyhost i will get the following error:

2017-03-28 08:33:52,106 proxy video encoders: 
2017-03-28 08:33:52,106 new proxy instance started
2017-03-28 08:33:52,106  for client tcp socket: 172.17.0.4:10050 <- 141.3.42.171:42458
2017-03-28 08:33:52,106  and server tcp socket: 172.17.0.4:58640 <- 172.17.0.3:10000
2017-03-28 08:33:52,107 Error: failed to setup control socket '/root/.xpra/xpra-proxy-proxy-2398':
2017-03-28 08:33:52,107  [Errno 13] Permission denied

on proxytarget i get

New tcp connection received from 172.17.0.4:58642

Any ideas how to trace the problem? Which debug flag should i enable?

Greets from Germany

#1481 fixed no xpra menu in systemtray with Ubuntu 17.04 B B
Description

Hi, if I run

xpra shadow ssh:andi@localhost \
    --no-clipboard --no-pulseaudio --no-printing --no-speaker \
    --no-cursors --dbus-control=no --dbus-proxy=no --use-display --no-daemon

xpra does not show up on system tray

Client os: xenial 17.04, xpra latest version

if i run xpra attach.....symbol shows up

greets

Note: See TracQuery for help on using queries.