xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#1117 closed defect (fixed)

Plink.exe crashes

Reported by: Brian Minton Owned by: Brian Minton
Priority: major Milestone:
Component: packaging Version: 0.17.x
Keywords: plink dll windows Cc:

Description

I'm using Xpra beta 0.17.0 revision 11892 on Windows Vista 32-bit. Plink.exe crashes with a missing DLL.

Attachments (1)

plink bug report.zip (228.5 KB) - added by Brian Minton 5 years ago.
bug report created by xpra bug report tool.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by Brian Minton

Attachment: plink bug report.zip added

bug report created by xpra bug report tool.

comment:1 Changed 5 years ago by Brian Minton

also, I have the following runtimes installed:
Microsoft Visual C++ 2013 Redistributable (x86) - 12.0.30501
Microsoft Visual C++ 2010 x86 Redistributable - 10.0.40219
Microsoft .NET Framework 4.6.1
Microsoft .NET Framework 3.5 SP1

comment:2 Changed 5 years ago by Antoine Martin

Status: newassigned

This is very likely to be caused by #1095 - I guess the new plink is win7 onwards only, which means that you should be able to copy the contents of TortoisePlink-XP into Xpra to fix it.
I will try to change the OS release detection to include vista.

comment:3 Changed 5 years ago by Brian Minton

That does not appear to be the problem. I downloaded the latest
TortoiseSVN, which includes Tortoiseplink.exe version 0.66. It worked
on my PC. After that, I was also able to run the plink.exe that came with
Xpra successfully (presumably because TortoiseSVN registered the DLLs).

Here is the list of windows api* DLLs installed in C:\Program Files\Xpra:

C:\Program Files\Xpra>dir api*.dll
 Volume in drive C has no label.
 Volume Serial Number is F09E-6874

 Directory of C:\Program Files\Xpra

12/13/2015  07:55 PM            18,624 api-ms-win-core-file-l1-2-0.dll
12/13/2015  07:55 PM            18,624 api-ms-win-core-file-l2-1-0.dll
12/13/2015  07:55 PM            21,184 api-ms-win-core-localization-l1-2-0.dll
12/13/2015  07:55 PM            19,136 api-ms-win-core-processthreads-l1-1-1.dll

12/13/2015  07:55 PM            19,136 api-ms-win-core-synch-l1-2-0.dll
12/13/2015  07:55 PM            18,624 api-ms-win-core-timezone-l1-1-0.dll
12/13/2015  07:55 PM            22,720 api-ms-win-crt-convert-l1-1-0.dll
12/13/2015  07:55 PM            19,136 api-ms-win-crt-environment-l1-1-0.dll
12/13/2015  07:55 PM            20,672 api-ms-win-crt-filesystem-l1-1-0.dll
12/13/2015  07:55 PM            19,648 api-ms-win-crt-heap-l1-1-0.dll
12/13/2015  07:55 PM            19,136 api-ms-win-crt-locale-l1-1-0.dll
12/13/2015  07:55 PM            29,376 api-ms-win-crt-math-l1-1-0.dll
12/13/2015  07:55 PM            26,816 api-ms-win-crt-multibyte-l1-1-0.dll
12/13/2015  07:55 PM            23,232 api-ms-win-crt-runtime-l1-1-0.dll
12/13/2015  07:55 PM            24,768 api-ms-win-crt-stdio-l1-1-0.dll
12/13/2015  07:55 PM            24,768 api-ms-win-crt-string-l1-1-0.dll
12/13/2015  07:55 PM            21,184 api-ms-win-crt-time-l1-1-0.dll
12/13/2015  07:55 PM            19,136 api-ms-win-crt-utility-l1-1-0.dll
              18 File(s)        385,920 bytes
               0 Dir(s)  18,834,812,928 bytes free

And here is the list of similar files installed in C:\Program Files\TortoiseSVN:

C:\Program Files\TortoiseSVN\bin>dir api*.dll
 Volume in drive C has no label.
 Volume Serial Number is F09E-6874

 Directory of C:\Program Files\TortoiseSVN\bin

12/13/2015  11:55 AM            19,136 api-ms-win-core-console-l1-1-0.dll
12/13/2015  11:55 AM            18,624 api-ms-win-core-datetime-l1-1-0.dll
12/13/2015  11:55 AM            18,624 api-ms-win-core-debug-l1-1-0.dll
12/13/2015  11:55 AM            18,624 api-ms-win-core-errorhandling-l1-1-0.dll
12/13/2015  11:55 AM            22,208 api-ms-win-core-file-l1-1-0.dll
12/13/2015  11:55 AM            18,624 api-ms-win-core-file-l1-2-0.dll
12/13/2015  11:55 AM            18,624 api-ms-win-core-file-l2-1-0.dll
12/13/2015  11:55 AM            18,624 api-ms-win-core-handle-l1-1-0.dll
12/13/2015  11:55 AM            19,136 api-ms-win-core-heap-l1-1-0.dll
12/13/2015  11:55 AM            19,136 api-ms-win-core-interlocked-l1-1-0.dll
12/13/2015  11:55 AM            19,136 api-ms-win-core-libraryloader-l1-1-0.dll
12/13/2015  11:55 AM            21,184 api-ms-win-core-localization-l1-2-0.dll
12/13/2015  11:55 AM            19,136 api-ms-win-core-memory-l1-1-0.dll
12/13/2015  11:55 AM            18,624 api-ms-win-core-namedpipe-l1-1-0.dll
12/13/2015  11:55 AM            19,648 api-ms-win-core-processenvironment-l1-1-0.dll
12/13/2015  11:55 AM            20,672 api-ms-win-core-processthreads-l1-1-0.dll
12/13/2015  11:55 AM            19,136 api-ms-win-core-processthreads-l1-1-1.dll
12/13/2015  11:55 AM            18,112 api-ms-win-core-profile-l1-1-0.dll
12/13/2015  11:55 AM            18,112 api-ms-win-core-rtlsupport-l1-1-0.dll
12/13/2015  11:55 AM            18,624 api-ms-win-core-string-l1-1-0.dll
12/13/2015  11:55 AM            20,672 api-ms-win-core-synch-l1-1-0.dll
12/13/2015  11:55 AM            19,136 api-ms-win-core-synch-l1-2-0.dll
12/13/2015  11:55 AM            19,648 api-ms-win-core-sysinfo-l1-1-0.dll
12/13/2015  11:55 AM            18,624 api-ms-win-core-timezone-l1-1-0.dll
12/13/2015  11:55 AM            18,624 api-ms-win-core-util-l1-1-0.dll
12/13/2015  11:55 AM            19,648 api-ms-win-crt-conio-l1-1-0.dll
12/13/2015  11:55 AM            22,720 api-ms-win-crt-convert-l1-1-0.dll
12/13/2015  11:55 AM            19,136 api-ms-win-crt-environment-l1-1-0.dll
12/13/2015  11:55 AM            20,672 api-ms-win-crt-filesystem-l1-1-0.dll
12/13/2015  11:55 AM            19,648 api-ms-win-crt-heap-l1-1-0.dll
12/13/2015  11:55 AM            19,136 api-ms-win-crt-locale-l1-1-0.dll
12/13/2015  11:55 AM            29,376 api-ms-win-crt-math-l1-1-0.dll
12/13/2015  11:55 AM            26,816 api-ms-win-crt-multibyte-l1-1-0.dll
12/13/2015  11:55 AM            73,408 api-ms-win-crt-private-l1-1-0.dll
12/13/2015  11:55 AM            19,648 api-ms-win-crt-process-l1-1-0.dll
12/13/2015  11:55 AM            23,232 api-ms-win-crt-runtime-l1-1-0.dll
12/13/2015  11:55 AM            24,768 api-ms-win-crt-stdio-l1-1-0.dll
12/13/2015  11:55 AM            24,768 api-ms-win-crt-string-l1-1-0.dll
12/13/2015  11:55 AM            21,184 api-ms-win-crt-time-l1-1-0.dll
12/13/2015  11:55 AM            19,136 api-ms-win-crt-utility-l1-1-0.dll
              40 File(s)        863,744 bytes
               0 Dir(s)  18,832,056,320 bytes free
Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:4 Changed 5 years ago by Antoine Martin

I'll have to dust up a Windows Vista VM to investigate.
We do not want to just blindly copy all the DLLs, I did spend a lot of time figuring out which ones were needed for win7...

comment:5 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to Brian Minton
Status: assignednew

So.. I dusted up a Vista VM, installed Windows 7 x86 in another VM so I could grab the dlls from the tortoise installation directory, added them one by one until the error went away (which is what I had done last time.. but obviously incorrectly). And this is the list that I got in the end:

 Directory of E:\Xpra-Build-Libs\TortoisePlink

16/02/2016  16:55    <DIR>          .
16/02/2016  16:55    <DIR>          ..
13/12/2015  04:55            19,136 api-ms-win-core-console-l1-1-0.dll
13/12/2015  04:55            18,624 api-ms-win-core-datetime-l1-1-0.dll
13/12/2015  04:55            18,624 api-ms-win-core-debug-l1-1-0.dll
13/12/2015  04:55            18,624 api-ms-win-core-errorhandling-l1-1-0.dll
13/12/2015  04:55            22,208 api-ms-win-core-file-l1-1-0.dll
13/12/2015  19:55            18,624 api-ms-win-core-file-l1-2-0.dll
13/12/2015  19:55            18,624 api-ms-win-core-file-l2-1-0.dll
13/12/2015  04:55            18,624 api-ms-win-core-handle-l1-1-0.dll
13/12/2015  04:55            19,136 api-ms-win-core-heap-l1-1-0.dll
13/12/2015  04:55            19,136 api-ms-win-core-interlocked-l1-1-0.dll
13/12/2015  04:55            19,136 api-ms-win-core-libraryloader-l1-1-0.dll
13/12/2015  19:55            21,184 api-ms-win-core-localization-l1-2-0.dll
13/12/2015  04:55            19,136 api-ms-win-core-memory-l1-1-0.dll
13/12/2015  04:55            18,624 api-ms-win-core-namedpipe-l1-1-0.dll
13/12/2015  04:55            19,648 api-ms-win-core-processenvironment-l1-1-0.dll
13/12/2015  04:55            20,672 api-ms-win-core-processthreads-l1-1-0.dll
13/12/2015  19:55            19,136 api-ms-win-core-processthreads-l1-1-1.dll
13/12/2015  04:55            18,112 api-ms-win-core-profile-l1-1-0.dll
13/12/2015  04:55            18,112 api-ms-win-core-rtlsupport-l1-1-0.dll
13/12/2015  04:55            18,624 api-ms-win-core-string-l1-1-0.dll
13/12/2015  04:55            20,672 api-ms-win-core-synch-l1-1-0.dll
13/12/2015  19:55            19,136 api-ms-win-core-synch-l1-2-0.dll
13/12/2015  04:55            19,648 api-ms-win-core-sysinfo-l1-1-0.dll
13/12/2015  19:55            18,624 api-ms-win-core-timezone-l1-1-0.dll
13/12/2015  04:55            18,624 api-ms-win-core-util-l1-1-0.dll
13/12/2015  19:55            22,720 api-ms-win-crt-convert-l1-1-0.dll
13/12/2015  19:55            19,136 api-ms-win-crt-environment-l1-1-0.dll
13/12/2015  19:55            20,672 api-ms-win-crt-filesystem-l1-1-0.dll
13/12/2015  19:55            19,648 api-ms-win-crt-heap-l1-1-0.dll
13/12/2015  19:55            19,136 api-ms-win-crt-locale-l1-1-0.dll
13/12/2015  19:55            29,376 api-ms-win-crt-math-l1-1-0.dll
13/12/2015  19:55            26,816 api-ms-win-crt-multibyte-l1-1-0.dll
13/12/2015  19:55            23,232 api-ms-win-crt-runtime-l1-1-0.dll
13/12/2015  19:55            24,768 api-ms-win-crt-stdio-l1-1-0.dll
13/12/2015  19:55            24,768 api-ms-win-crt-string-l1-1-0.dll
13/12/2015  19:55            21,184 api-ms-win-crt-time-l1-1-0.dll
13/12/2015  19:55            19,136 api-ms-win-crt-utility-l1-1-0.dll
13/12/2015  19:55           439,608 msvcp140.dll
13/12/2015  23:23           400,768 TortoisePlink.exe
13/12/2015  19:55           921,280 ucrtbase.dll
13/12/2015  19:55            85,328 vcruntime140.dll
              41 File(s)      2,598,024 bytes
               2 Dir(s)   1,953,193,984 bytes free

Looks like we're skipping a few we don't need. I hope we don't need them on another platform...

I then rebuilt the installer and tested it on a clean Vista VM.
The latest beta build can be found here: http://xpra.org/beta/windows/.

@bjmgeek: does this work for you? If so, please close this ticket.

comment:6 Changed 4 years ago by Brian Minton

Resolution: fixed
Status: newclosed

comment:7 Changed 4 years ago by Brian Minton

Fixed in newest beta.

Note: See TracTickets for help on using tickets.