xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

#1143 closed defect (invalid)

OSX client unpacking - "error parsing the Info.plist"

Reported by: Kerry Owned by: Kerry
Priority: major Milestone: 0.17
Component: client Version: trunk
Keywords: osx Cc:

Description (last modified by Antoine Martin)

3/10/16 10:30:42.098 AM Finder[494]: There was an error parsing the Info.plist for the bundle at URL Contents/Info.plist -- file:///Applications/Xpra.app/Contents/Xpra_NoDock.app/
 The data couldn’t be read because it isn’t in the correct format.
 <CFBasicHash 0x60000127dc80 [0x7fff768e1ed0]>{type = immutable dict, count = 2,
entries =>
	0 : <CFString 0x7fff768ac660 [0x7fff768e1ed0]>{contents = "NSDebugDescription"} = <CFString 0x600000a4e5b0 [0x7fff768e1ed0]>{contents = "Encountered unexpected EOF"}
	1 : <CFString 0x7fff768b96c0 [0x7fff768e1ed0]>{contents = "kCFPropertyListOldStyleParsingError"} = Error Domain=NSCocoaErrorDomain Code=3840 "The data couldn’t be read because it isn’t in the correct format." (Malformed data byte group at line 1; invalid hex) UserInfo=0x60000086fd80 {NSDebugDescription=Malformed data byte group at line 1; invalid hex}
}

If you try to run Xpra client after this, it immediately crashes with "abnormal code 126"

Dump attached.

Attachments (1)

Xpra-Launcher_2016-03-09-163955_KVERNE-M-91MH.crash (85.3 KB) - added by Kerry 4 years ago.
OSX crash dump

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by Kerry

OSX crash dump

comment:1 Changed 4 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Kerry

That's odd: no-one else has ever reported this problem and the image works fine when I run it in my 10.10 VM.
I see nothing wrong in that file either: browser/xpra/tags/v0.16.x/osx/Xpra_NoDock.app/Contents/Info.plist.
It's almost identical to the one used for the main package: browser/xpra/tags/v0.16.x/osx/Info.plist.

Is this a regression? What version are you running?

comment:2 Changed 4 years ago by Kerry

Resolution: invalid
Status: newclosed

Evidently I had corruption issues on the download. Tried twice with errors last week. Works fine now.

Resolving as invalid.

Note: See TracTickets for help on using tickets.