xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1146 closed defect (fixed)

KDE - System Tray Icon is tiny

Reported by: J. Max Mena Owned by: J. Max Mena
Priority: minor Milestone: 0.17
Component: client Version: trunk
Keywords: KDE Cc:

Description

As the title suggests, when using the latest Plasma Desktop in Fedora 23, Xpra clients create a very very very small icon in the system tray. I would guess that it's 4x4 pixels in size. It works perfectly fine, but is very hard to click.

I'll attach a screenshot to demonstrate.


Versions:

Fedora 23 64-bit

Xpra trunk r12147

Attachments (2)

1146 screenshot.png (12.2 KB) - added by J. Max Mena 4 years ago.
screenshot to demonstrate. The icon is between the printer and the sound icons...it's quite small.
systray-kubuntu-1404.png (50.5 KB) - added by Antoine Martin 4 years ago.
systray looking fine with Kubuntu 14.04

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by J. Max Mena

Attachment: 1146 screenshot.png added

screenshot to demonstrate. The icon is between the printer and the sound icons...it's quite small.

comment:1 Changed 4 years ago by J. Max Mena

For the life of me I have no idea how to get the KDE version....

If you want logs of some sort, let me know.

comment:2 Changed 4 years ago by Antoine Martin

Could be related to #1016.

comment:3 Changed 4 years ago by Antoine Martin

Status: newassigned

comment:4 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to J. Max Mena
Status: assignednew

This may help: r12242 + r12245

@maxmylyn: does it make any difference, please include the -d tray output

Changed 4 years ago by Antoine Martin

Attachment: systray-kubuntu-1404.png added

systray looking fine with Kubuntu 14.04

comment:5 Changed 4 years ago by Antoine Martin

Keywords: KDE added
Priority: trivialminor

As can be seen here (tested with 0.17 latest):
systray looking fine with Kubuntu 14.04
The systray looks fine with Trusty (I also tested with 0.16.3) - maybe KDE 4.13 is before the breakage?, it also looks fine with opensuse 13.2 which uses KDE 4.14 (tested with both xpra 0.16 and 0.17) but I do see the problem with Fedora 23 (also KDE 4.14)...
(I wanted to try KDE on Ubuntu 15.10, but it just won't load the desktop)


It is kind of "fixed" by the changes from comment:4 (which I will backport) in that at least the systray is more or less the right size now, but it still doesn't look great, and even more strange: it worked the first time I connected, but not the second. (something in KDE is getting wedged badly - you have to logout and log back in to make it work again, what an epic fail)
Even worse: the clicks on the tray do nothing if you click+release quickly, despite the fact that we receive exactly the same events as when doing a slow click+release.
This can be seen with -d tray,menu.
The exact same code also fires when doing a Alt+Shift+F1, except this works every time.

For more details on this API horror show, see ticket:1016#comment:1.


@maxmylyn: if the size is improved, let's close this ticket and follow up in #1016.

comment:6 Changed 4 years ago by J. Max Mena

Resolution: fixed
Status: newclosed

Well.....at least it's clickable, and the size is more or less what it should be.

I am also seeing the issue where it won't show back up again until I log out and back in...I guess I'll just have to refrain from disconnecting ;)

Closing.

comment:7 Changed 4 years ago by J. Max Mena

Of note as of the week of 6/13/2016:

There must have been an update with KDE because my Icon comes back after disconnecting and reconnecting. Either way it's working fine now.

Note: See TracTickets for help on using tickets.