xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

#1149 closed defect (worksforme)

win32 shadow server crashes with bind-tcp and -d sound,gstreamer

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 0.17
Component: platforms Version: trunk
Keywords: win32 Cc:

Description

This command line:

xpra_cmd shadow --bind-tcp=0.0.0.0:10000 -d sound,gstreamer

crashes in a very odd place (importing win32ui):

xpra main error:
Traceback (most recent call last):
  File "xpra\scripts\main.pyc", line 125, in main
  File "xpra\scripts\main.pyc", line 979, in run_mode
  File "xpra\scripts\server.pyc", line 1099, in run_server
  File "xpra\platform\shadow_server.pyc", line 9, in <module>
  File "xpra\platform\__init__.pyc", line 150, in platform_import
  File "xpra\platform\win32\shadow_server.pyc", line 11, in <module>
ImportError: DLL load failed: Invalid access to memory location.

It works fine with -d all, just -d sound or -d gstreamer, but not with this particular combination!

Change History (3)

comment:1 Changed 3 years ago by Antoine Martin

Status: newassigned

Could just be because of the amount of logging that goes on. See also #1150.
Maybe we should log to a file or to the system log instead (NTEventLogHandler)

comment:2 Changed 3 years ago by Antoine Martin

Reminiscent of #1094, similar fix to r11736? (gobject threads init early)

Last edited 3 years ago by Antoine Martin (previous) (diff)

comment:3 Changed 3 years ago by Antoine Martin

Resolution: worksforme
Status: assignedclosed

Can no longer reproduce!

Could also have been related to changeset/8786/xpra (see win32ttywrite workaround).

Note: See TracTickets for help on using tickets.