xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1156 closed defect (invalid)

Wacom Tablet - Holding scroll button does not block clicks

Reported by: J. Max Mena Owned by: J. Max Mena
Priority: minor Milestone: 1.0
Component: client Version: trunk
Keywords: Cc:

Description

As Antoine requested, this a related ticket of #1131.

The expected behavior is:

  • Hold scroll button
  • Touch pen to surface and move to scroll
  • Repeat to scroll further, releasing the pen to move back to scroll again.

As of now, touching the pen to the surface sends a click when the pen is released, even though the scroll button is held down.

Let me know what logs you need for this.

Change History (7)

comment:1 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to J. Max Mena

Please include debug output. I do not have such a tablet, I cannot write the code blindly.

comment:2 Changed 4 years ago by J. Max Mena

Sorry I forgot to include it in the original post. That's my bad.

We're very busy this week, so I probably won't have the time to get the logs for this one and #1157 until probably Friday.

comment:3 Changed 4 years ago by Antoine Martin

Milestone: 0.170.18

Too late for 0.17

comment:4 Changed 4 years ago by J. Max Mena

Update:

Finally had some time to get around to trying this out. I tried the tablet on a couple other machines and it scrolls fine, and I don't see any of the behavior in the description. We decided to reinstall Windows on the machine that had the issue, and it's kinda dead right now. I'm tempted to close this as invalid, but we'll try again on that machine with a fresh copy of Windows.

We decided to reinstall Windows when it turns out that scrolling of any and all kind wasn't working anymore, and the issue was limited to that single machine.

comment:5 Changed 4 years ago by J. Max Mena

@antoine:

I suggest we close this ticket, as the issue was limited to just the one machine and I haven't seen it since.

comment:6 Changed 4 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

Agreed.

comment:7 Changed 4 years ago by Antoine Martin

Milestone: 0.181.0

Milestone renamed

Note: See TracTickets for help on using tickets.