xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.

Opened 6 years ago

Closed 6 years ago

Last modified 16 months ago

#1168 closed task (fixed)

switch to gstreamer 1.8 on osx

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: blocker Milestone: 1.0
Component: platforms Version: trunk
Keywords: osx Cc:


Follow up from #1069.

Change History (11)

comment:1 Changed 6 years ago by Antoine Martin

See also: r12468.
Hopefully this is not a problem with 1.8, but something specific to Ubuntu?

comment:2 Changed 6 years ago by Antoine Martin

Milestone: 0.181.0

Milestone renamed

comment:3 Changed 6 years ago by Antoine Martin

Priority: majorcritical

Raising: el-capitan is not happy with the audio API used, newer versions may fix this: WARNING: 140: This application, or a library it uses, is using the deprecated Carbon Component Manager for hosting Audio Units. Support for this will be removed in a future release. Also, this makes the host incompatible with version 3 audio units. Please transition to the API's in AudioComponent?.h.

comment:4 Changed 6 years ago by Antoine Martin

Priority: criticalblocker

Raising, blocker for #1276.

comment:5 Changed 6 years ago by Smo

r13389 updates gstreamer-1.0 to 1.8.2
r13390 updates gst-plugins-base-1.0 to 1.8.2
r13392 uses patch from previous 1.6.4 to fix defines
r13393 updates gst-plguins-ugly-1.0 to 1.8.2
r13395 updates gst-plugins-bad-1.0 to 1.8.2

plugins-bad-1.0 seems to stall during compile with these errors from gst-plugin-scanner

(gst-plugin-scanner:96515): GLib-GObject-WARNING **: cannot register existing type 'GstRtpH265Depay'
(gst-plugin-scanner:96515): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed
(gst-plugin-scanner:96515): GStreamer-CRITICAL **: gst_element_register: assertion 'g_type_is_a (type, GST_TYPE_ELEMENT)' failed

tried to remove GstRtpH265Depay with r13396 but this doesn't seem to fix the problem

We really need some of the modules in plugins-bad if we can't make this work we may have to revert back to 1.6.4

I'll continue to try and make this work.

comment:6 Changed 6 years ago by Smo

Tried to resolv this by removing more modules which turns out not to be the actual problem.

r13396 disables libde265
r13397 disables mpeg modules
r13398 disables gtk

Answer came from here


rm ~/gtk/inst/lib/gstreamer-1.0/libgstrtpbad.so

Turns out there really was a duplicate because some code was moved into plugins-good and we still had the module installed from 1.6.4

Everything we need builds now but still needs some testing.
I'm going to leave the modules i've disabled for the time being if there is any issue we can always revert back.
We might even consider another ticket for disabling more gstreamer modules we don't use.

comment:7 Changed 6 years ago by Antoine Martin

We trim the list of plugins we ship in the osx build scripts, so it shouldn't really matter if we have or don't have those extra modules installed on the build system.

comment:8 Changed 6 years ago by Antoine Martin

FYI: 1.8.3 is out, see Release notes for GStreamer 1.8.3

comment:9 Changed 6 years ago by Smo

Owner: changed from Smo to Antoine Martin

r13621 changes these to 1.8.3

I've built them with no issue should be tested.

comment:10 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Looks good, quickly tested with a few codecs without problems.
Can be re-tested as part of #1276 so closing for now.

comment:11 Changed 16 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1168

Note: See TracTickets for help on using tickets.