Xpra: Ticket #1270: Compiling --without-vpx still pulls in vpx functionality

I'm compiling xpra 0.17.4 on Ubuntu 14.04 from source with --without-vpx, but the vpx libraries are still being pulled in.

This produces a crash on 14.04 in reference to: https://www.xpra.org/trac/ticket/1084

Therefore it's impossible to get xpra 0.17.4 to run on 14.04.

0.16.0 (previous version I compiled) worked fine with --without-vpx, and the vpx initialization was skipped properly.

Not sure why --without-vpx is not working. The first time I compiled it I forgot to use --without-vpx. I then installed it and realized the mistake. I ran ./setup.py clean and recompiled with --without-vpx.

I tried rm -rf build also before recompiling and installing, but makes no difference.

Why is --without-vpx not working, and how do I disable it in 0.17.4?

Where in the code are the vpx libraries being initialized. Is there something I can comment out manually?

Thank you.

Sat, 30 Jul 2016 10:14:33 GMT - Casper:

Manually commenting out all references to vpx in xpra/codecs/loader.py disabled vpx properly.

Sat, 30 Jul 2016 13:57:53 GMT - Casper: status changed; resolution set

Sat, 30 Jul 2016 15:41:07 GMT - Antoine Martin: status changed; resolution deleted

No. This change is definitely NOT correct. Do not do this. Anyone reading this ticket should not follow these instructions.

You must have had some old build laying around. Make sure you clear everything before you install again and you will not have vpx included, and it will not be found:

rm -fr build dist/ install
./setup.py install --without-vpx --home=./install
find install/ -name "*vpx*"
PYTHONPATH=./install/lib64/python python ./install/lib64/python/xpra/codecs/loader.py

Sat, 30 Jul 2016 15:41:41 GMT - Antoine Martin: status changed; resolution set

--without-vpx works as expected, as shown in comment:3.

Sat, 23 Jan 2021 05:19:40 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1270