xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.

Opened 6 years ago

Closed 6 years ago

Last modified 16 months ago

#1272 closed defect (invalid)

pycallgraph throwing ImportError

Reported by: alas Owned by: Antoine Martin
Priority: major Milestone: 1.0
Component: server Version: trunk
Keywords: Cc:


Trying to use the pycallgraph function, I'm getting an ImportError.

Traceback (most recent call last):
  File "./tests/scripts/pycallgraph", line 7, in <module>
    from pycallgraph import PyCallGraph, Config
ImportError: No module named pycallgraph

I'm trying to run with the following command, after building:

[jimador@jimador src]$ ./tests/scripts/pycallgraph -d 123 -I "*.do_send_delayed_regions,*._refresh_region" -- start :13 --no-notification --no-daemon --start-child=xterm --no-mdns --bind-tcp=

Tried building all the way back to 0.15.x, got the same error with all:

  • xpra server version 0.15.6 (r13070)
  • xpra X11 version 0.16.4-r11617 (unknown changes) (built with an svn up, looks like version number isn't changing to reflect in connection output or !Session Info)
  • xpra X11 version 0.17.1-r12453 (unknown changes) (also with svn up, probably around 13070, if there have been any changes backported)
  • xpra X11 version 1.0-r13165 64-bit

... possibly also worth noting, with all the server builds except the 1.0, I saw the following output client-side, which didn't seem to impact performance at all (not that I tested performance much, but the connections seemed functional): av_log: vsnprintf returned -1 on format string 'user data:"%s"'.

Change History (2)

comment:1 Changed 6 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

See ticket:620#comment:21 where you already posted the exact same question.
Answer: install pycallgraph.

Please report the av_log problem separately with more details (what encoding, command line, etc)

Last edited 6 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 16 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1272

Note: See TracTickets for help on using tickets.