xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1318 closed defect (fixed)

Unable to connect with --no-windows

Reported by: J. Max Mena Owned by: Antoine Martin
Priority: major Milestone: 1.0
Component: server Version: 0.17.x
Keywords: Cc:

Description

The Server is a 0.17.5-r13455-2 Running on a Debian Jessie machine, and the clients (attempted from two different machines) were a 0.17.5-r13487 Win8.1 and a 0.17.5-2r13455 Fedora 24 machine.

Connecting with both machines will print the following traceback and then disconnect the client:

2016-09-20 18:50:20,115 server error processing new connection from Protocol(tcp socket: 192.168.1.200:2200 <- 192.168.1.109:49912): cannot send windows/encodings without an encoding!
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/xpra/server/server_base.py", line 1080, in parse_hello_ui
    self.do_parse_hello_ui(ss, c, auth_caps, send_ui, share_count)
  File "/usr/lib/python2.7/dist-packages/xpra/server/server_base.py", line 1100, in do_parse_hello_ui
    self.send_hello(ss, root_w, root_h, key_repeat, auth_caps)
  File "/usr/lib/python2.7/dist-packages/xpra/server/server_base.py", line 1319, in send_hello
    server_source.hello(capabilities)
  File "/usr/lib/python2.7/dist-packages/xpra/server/source.py", line 1314, in hello
    assert self.encoding, "cannot send windows/encodings without an encoding!"
AssertionError: cannot send windows/encodings without an encoding!

The server was started with xpra start :13 --bind-tcp=0.0.0.0:2200 --start-new-commands=yes --start-child=xterm --sharing --no-daemon

And the attach command was the usual Xpra_cmd.exe attach tcp:ip:port --no-windows

If you need anything else, let me know!

Change History (3)

comment:1 Changed 3 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Fixed in r13787, another warning fixed in r13788.

comment:2 Changed 3 years ago by J. Max Mena

Note: r13787 and r13788 are not in the Debian Jessie amd64 repo - hence why the issue is persisting on my machine. Upgrading them to trunk fixed the issue due to having newer builds.

comment:3 Changed 3 years ago by Antoine Martin

Latest greatest beta builds are now available for all distros.

Note: See TracTickets for help on using tickets.