xpra icon
Bug tracker and wiki

Opened 8 years ago

Closed 8 years ago

#144 closed defect (fixed)

"AssertionError" in free_image when resizing a window using x264 encoding

Reported by: ahuillet Owned by: ahuillet
Priority: major Milestone: 0.4
Component: client Version: 0.1.0
Keywords: Cc:

Description (last modified by Antoine Martin)

This is easy to reproduce:

Error while decoding frame
 paint_with_video_decoder: ouch, decompression error 2
Unhandled error while processing packet from peer
(..)
File "/usr/lib64/python2.7/site-packages/xpra/window_backing.py", line 104, in paint_with_video_decoder
 decoder.free_image()
File "codec.pyx", line 87, in xpra.x264.codec.Decoder.free_image (xpra/x264/codec.c:1397)
AssertionError

It happens every time (or almost?) one resizes a window. This looks like a race condition - as if the client was resetting its decoding context *after* trying to play one wrong frame?

Change History (3)

comment:1 Changed 8 years ago by ahuillet

Owner: changed from Antoine Martin to ahuillet
Status: newassigned

comment:2 Changed 8 years ago by Antoine Martin

Description: modified (diff)
Milestone: 0.30.4

comment:3 Changed 8 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

fixed in r977 - will apply to stable 0.3.x branch after further testing

feel free to re-open if you can still reproduce this bug

Note: See TracTickets for help on using tickets.