xpra icon
Bug tracker and wiki

Opened 5 months ago

Closed 2 months ago

#1505 closed defect (needinfo)

Windows get shifted outside screen when (even sligtly) shifted on client side

Reported by: anygoe Owned by: anygoe
Priority: major Milestone: 2.1
Component: client Version: trunk
Keywords: shift, resize, local window interaction, QT Cc:

Description

Dear experts,

After some fruitless attempts (playing around with different command line parameters, etc.) I am running out of ideas, with the following issue:

From my Win7-PC, (and leaving out additional parameters I tried, but which didn't help with my problem) I connect to my Linux PC (UBUNTU 14.04) using

xpra ssh/<usr>@<IP> --start=xterm

which works fine. In xterm, I start a docker emulation of another UBUNTU system, which gives me another xterm window on my Windows client. Again no problem there. Now, inside the docker, I start a user program, creating a bunch of (most probably QT-generated) GUIs. These are initially displayed correctly, but when I try to shift them on my local screen - even with only tiny movements, and independent in which direction I try to move) - they get pushed towards the lower right corner and finally disappear from the screen. Same happens, when I try to scale them ... scaling is "amplified" and windows are pushed to the lower right area.

Again, (just to be clear) there is no such behavior, when I move/scale the other (xterm) windows. Looks to me like this is a QT-related issue but I am not sure. I already tried to find related discussions here, but I didn't find any. So, has someone of you seen such a behavior (in any setup) before?

Thanks a lot in advance,
Andy

Change History (4)

comment:1 Changed 5 months ago by Antoine Martin

Owner: changed from Antoine Martin to anygoe

Is docker relevant to this question or does this also happen without involving docker? Have you tried running the client with "--desktop-scaling=no"?
Which Qt application can we use to reproduce this bug?
Can you post the log output of both the client and the server running with the flag "-d geometry" when this happens?

comment:2 Changed 5 months ago by anygoe

Thanks for your reply/suggestion(s). I don't think that the docker itself is the problem and it would be hell of work to justify this. We are using it to emulate the develpment environment (confusingly also a UBUNTU Linux system) required to run the new software.

Starting the docker while sitting in front of my Linux machine (i.e. the one which I remotely connect via xpra), all windows showing up (also the docker ones) don't show any related strange behavior.

Yes, I tried with deactivated scaling and also with deactivated opengl rendering, but without positive effect.

I just added "-d geometry" to the command I mentioned in my initial post, but I will have to find out, where the output goes. Also I will have to find out how to do this on server side (I just started with xpra). I'll come back with the result asap.

In the docker, libqt4-dev is included, so I suppose this is the version compatible with the QT GUIs. If required, I can try to get more specific information.

Last edited 5 months ago by anygoe (previous) (diff)

comment:3 Changed 5 months ago by Antoine Martin

You can enable "-d geometry" simply by editing your command line, or at runtime using the control channel:

xpra control tcp/host:port/ debug enable geometry

But the easiest way of fixing this would be to provide a simple sample Qt application that we can reproduce the problem with in an Ubuntu 14.04 VM.

comment:4 Changed 2 months ago by Antoine Martin

Milestone: 2.1
Resolution: needinfo
Status: newclosed
Note: See TracTickets for help on using tickets.