xpra icon
Bug tracker and wiki

Opened 8 months ago

Closed 8 months ago

#1506 closed defect (invalid)

Version. 2.1. Session start and Socket availability

Reported by: Denis01 Owned by: Denis01
Priority: major Milestone: 2.1
Component: server Version: trunk
Keywords: Cc:

Description

Seems that there are issues with sessions' start. And from Terminal commands and from PY scripts.

  • session is started but port is closed (even after 20 secs of waiting)
  • Proxy can't connect due to
    "File "/usr/lib64/python2.7/site-packages/xpra/net/protocol.py", line 993, in steal_connection
        assert not self._closed, "cannot steal a closed connection"
    AssertionError: cannot steal a closed connection"
    
  • other messages like
    Xpra: Fatal IO error 11 (Resource temporarily unavailable) on X server :4.
    (gedit:3970): Gdk-WARNING **: gedit: Fatal IO error 11 (Resource temporarily unavailable) on X server :4.
    

Change History (6)

comment:1 Changed 8 months ago by Denis01

Component: testscore
Summary: Version. 2.0.1. Session start and Socket availabilityVersion. 2.1. Session start and Socket availability

comment:2 Changed 8 months ago by Antoine Martin

Component: coreserver
Owner: changed from Antoine Martin to Denis01

As always, please follow wiki/ReportingBugs. In particular:

  • os and version
  • exact steps to reproduce

etc..

Last edited 8 months ago by Antoine Martin (previous) (diff)

comment:3 Changed 8 months ago by Denis01

Centos 7.x
The easiest way is to put a call for a new session for user on target hosts in xx_auth.py/get_sessions() on Proxy server. Basically 1 connection can be established normally but then there are more than 1 session on 1 target_host - behavior of proxy/sessions/ports is unpredictable (mentioned above).

Version 2.0.2 reliably starts many sessions with ports open less then 3 sec for users. Proxy connects html client easily. With the same ssh paramico call from the same xxx_auth.get_session() function.
Tested today and 2.1 and 2.0
.2 on the same server and 2 auth modules(multi and sql).
Seems that it could be somehow linked with new in 2.1 "flag of stealing session" or other modif.

P.s. almost happy :-) as it got me absolutly mad :-) so getting back to normalize balancing script

comment:4 Changed 8 months ago by Antoine Martin

Please provide reproducible steps for this issue with any supported xpra version, without making changes to the code.
Otherwise I will have to close this ticket as "invalid".
I am also having a very hard time understanding your comments.

comment:5 Changed 8 months ago by Denis01

Having tried with different scenarios I was unable to reproduce that with Terminal use only.
So the all descriptions are relevant only to the calls from the modified code.

comment:6 Changed 8 months ago by Antoine Martin

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.