xpra icon
Bug tracker and wiki

Opened 2 months ago

Closed 6 weeks ago

#1580 closed task (fixed)

sub-pixel rendering test application

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 2.2
Component: core Version: trunk
Keywords: Cc:

Description

Follow up from #559.

The same way that #1553 provided a test application for #1309 (image depth settings), we should provide test applications for sub-pixel rendering.

Attachments (2)

fontrendering.png (75.3 KB) - added by Antoine Martin 7 weeks ago.
screenshot of the new fontrendering test application
fontrendering-win32.png (62.4 KB) - added by Antoine Martin 7 weeks ago.
test app running on win32

Download all attachments as: .zip

Change History (5)

comment:1 Changed 2 months ago by Antoine Martin

Milestone: 3.02.2
Status: newassigned

Changed 7 weeks ago by Antoine Martin

Attachment: fontrendering.png added

screenshot of the new fontrendering test application

Changed 7 weeks ago by Antoine Martin

Attachment: fontrendering-win32.png added

test app running on win32

comment:2 Changed 7 weeks ago by Antoine Martin

r16604 adds a test application (very slow to run..), which looks like this on Linux (with or without xpra):
screenshot of the new fontrendering test application

The right hand side shows the difference between the antialias setting shown on the left and the "NONE" setting.

So far it shows that I am unable to force sub-pixel rendering to turn on, only gray (which is the default is seems).

Interestingly, it does enable sub-pixel rendering on MS Windows where the colours are clearly visible on the deltas:
test app running on win32
Looks like it uses more blue on the right hand side, and orange (red) on the left. So this would imply an RGB sub-pixel order which is correct. (this inverted since we XOR the two images!)
And this is confirmed by the value retrieved through the API, see Native_GUI.exe output.

Last edited 6 weeks ago by Antoine Martin (previous) (diff)

comment:3 Changed 6 weeks ago by Antoine Martin

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.