xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.

Opened 5 years ago

Closed 5 years ago

Last modified 17 months ago

#1619 closed defect (invalid)

Can not specify password on client when using attach

Reported by: Alexander Owned by: Antoine Martin
Priority: major Milestone: 2.2
Component: client Version: 2.1.x
Keywords: Cc:



I create a session on the server:

xpra start :4 --start-child=firefox --exit-with-children --exit-with-client --bind-tcp= --auth=password:value=temp

How do I specify the password "temp" on the client using "attach"?
It turns out only if you save the password "temp" in the file "password.txt".
And further on the client:

Xpra_cmd attach tcp:serverIP:10001 --password-file=./password.txt

Without creating a file with a password, you can not tell the password at once in the connection command?
For example,

Xpra_cmd attach tcp:serverIP:10001 --password=temp

Tried everything, does not work.
I tried on Xpra 2.1.1 and 2.0.3 for Windows (32 and 64 bit)

Change History (3)

comment:1 Changed 5 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

Use the syntax:

xpra attach "tcp/username:password@host:port/"

comment:2 Changed 5 years ago by Alexander

Working! Thank you!
My mistake was that I did not specify the login. Judging by the manuals on the site, the _login_ is not indicated anywhere when using TCP (SSH only).

comment:3 Changed 17 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1619

Note: See TracTickets for help on using tickets.