xpra icon
Bug tracker and wiki

Opened 3 months ago

Closed 3 months ago

#1628 closed defect (worksforme)

How to clear all sessions after server reboot?

Reported by: Alexander Owned by: Alexander
Priority: minor Milestone: 2.2
Component: client Version: 2.1.x
Keywords: Cc:

Description

Hello.

If you reboot the server while the Xpra session was running on it, then after restarting the session, they appear as
UNKNOWN SESSION
It is necessary to do on the Windows client first

xpra stop :number_display

and then
It is necessary to do on the Windows client first

xpra start :number_display other_command

It would be desirable after a server reboot to clear all sessions that existed before the reboot. Something like:

xpra clear ALL

That the client did not send:

xpra stop :number_display

How can I do that? Thank you.

Change History (4)

comment:1 Changed 3 months ago by Antoine Martin

Owner: changed from Antoine Martin to Alexander

You don't need to stop the dead sessions. What makes you think that you do?
Simply running:

xpra list

will clear them.

And trying to start a new session should also work, though it may take a little while longer as it probes the dead socket.

comment:2 Changed 3 months ago by Alexander

But you just have to go through a third-party client (from Windows) through ssh to run the command

xpra list

What options to specify on xpra_cmd.exe for 'xpra list'?
I tried to specify in the file ~/.bashrc:

xpra list

(Also: 'xpra list &&', 'xpra lis&& sleep 5').
But after restarting the server, centos does not connect after on:

xpra_cmd start :1 --start-child=firefox --close-with-children --close--with-client

Xpra_cmd informs (asked):

Error: failed to receive anything, not an xpra server? could also be the wrong protocol, username, password or port.
Connection on lost

Then I use a third-party ssh client to enter 'xpra stop'.
And everything starts to work after running the already described command

xpra_cmd start :1 --start-child=firefox --close-with-children --close--with-client

Worked.
How do I not use a third-party ssh client?

comment:3 Changed 3 months ago by Antoine Martin

Please show the exact commands that you are using. AFAICT, this is not a valid command:

xpra_cmd start :1 --start-child=firefox --close-with-children --close--with-client

As there is no "start" command on MS Windows.

If you are trying to start the server on a specific display, try removing the display number and let xpra choose the display for you - maybe it will choose one that doesn't need to wait for the sockets to timeout.

comment:4 Changed 3 months ago by Antoine Martin

Component: androidclient
Resolution: worksforme
Status: newclosed

Cannot reproduce: my centos7 VM takes a little while longer to start sessions when there are dead sockets, but it remote ssh start does eventually work.

Closing. If you want to see this bug fixed, please add more details as per wiki/ReportingBugs.

Note: See TracTickets for help on using tickets.