xpra icon
Bug tracker and wiki

#1811 closed defect (fixed)

Changing Scaling before Drawing crashes

Reported by: stdedos Owned by: Antoine Martin
Priority: major Milestone: 2.3
Component: client Version: 2.2.x
Keywords: Cc:

Description

Changing the scaling during a shadow crashes with:

Traceback (most recent call last):
  File "./xpra/client/gtk_base/gtk_tray_menu_base.py", line 855, in scaling_activated
  File "./xpra/client/ui_client_base.py", line 1067, in scaleset
  File "./xpra/client/ui_client_base.py", line 1096, in scale_change
TypeError: 'NoneType' object is not iterable

Change is made before showing the screens

Change History (4)

comment:1 Changed 15 months ago by stdedos

during a shadow: during attach of an already-started shadow

comment:2 Changed 15 months ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos

This looks like a harmless stacktrace.
r19018 should avoid that, both from the tray menu or key shortcuts.
r19019 also grays out the tray menu entries until the server connection is fully established.

If you still have problems, please provide steps to reproduce.

comment:3 Changed 15 months ago by stdedos

Owner: changed from stdedos to Antoine Martin

Not able to reproduce, as you blocked the avenue for doing so :-D. Setting from the command line does not affect.

I'd of course prefer if the option was allowed to be set for the future (i.e. as kind of given through the command line), but I can accept fix as resolution.

comment:4 Changed 15 months ago by Antoine Martin

Component: androidclient
Milestone: 2.3
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.