xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 9 years ago

Closed 9 years ago

Last modified 8 months ago

#183 closed defect (fixed)

client side protocol errors

Reported by: onlyjob Owned by: Antoine Martin
Priority: minor Milestone: 0.5
Component: core Version: trunk
Keywords: Cc:

Description

There is a minor regression introduced in 0.5.2 and 0.6.0:
when mouse cursor moved over attached application window (I tried with kwrite on Debian Wheezy) client-side xpra prints the following errors to console:

0.5.2:

2012-09-01 21:05:54,907 Unhandled error while processing packet from peer
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/xpra/protocol.py", line 457, in _process_packet
    self._process_packet_cb(self, decoded)
  File "/usr/lib/python2.7/dist-packages/xpra/client.py", line 851, in process_packet
    XpraClientBase.process_packet(self, proto, packet)
  File "/usr/lib/python2.7/dist-packages/xpra/client_base.py", line 213, in process_packet
    handler(packet)
  File "/usr/lib/python2.7/dist-packages/xpra/client.py", line 770, in _process_cursor
    set_windows_cursor(self._id_to_window.values(), new_cursor)
  File "/usr/lib/python2.7/dist-packages/xpra/client.py", line 27, in set_windows_cursor
    pixbuf = gdk.pixbuf_new_from_data(pixels, gdk.COLORSPACE_RGB, True, 8, w, h, w * 4)
ValueError: data length (0) is less then required by the other parameters (9216)

0.6.0:

2012-09-01 21:14:39,693 Unhandled error while processing packet from peer
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/xpra/protocol.py", line 471, in _process_packet
    self._process_packet_cb(self, decoded)
  File "/usr/lib/python2.7/dist-packages/xpra/client.py", line 879, in process_packet
    XpraClientBase.process_packet(self, proto, packet)
  File "/usr/lib/python2.7/dist-packages/xpra/client_base.py", line 216, in process_packet
    handler(packet)
  File "/usr/lib/python2.7/dist-packages/xpra/client.py", line 798, in _process_cursor
    set_windows_cursor(self._id_to_window.values(), new_cursor)
  File "/usr/lib/python2.7/dist-packages/xpra/client.py", line 27, in set_windows_cursor
    pixbuf = gdk.pixbuf_new_from_data(pixels, gdk.COLORSPACE_RGB, True, 8, w, h, w * 4)
ValueError: data length (0) is less then required by the other parameters (9216)

Apparently nothing is broken - everything still works despite the errors printed. 0.5.1 do not have this issue.

Thanks.

Change History (4)

comment:1 Changed 9 years ago by Antoine Martin

Status: newaccepted

Yes, thanks for creating a bug for this.
I am aware of the problem and I am trying to find a good solution (which is not easy when trying to keep backwards compatibility..)

What happens is that we send compressed packets and these ones happened not to be flushed out, so the packet size is zero... this used to work before but was an accident!

comment:2 Changed 9 years ago by Antoine Martin

Resolution: fixed
Status: acceptedclosed

This was caused by r1402 and should be fixed in r1476 for trunk, r1477

Will issue a minor update for all stable branches (a bit too many of those now... testing connections from all supported versions as both client and server took some effort!)

comment:3 Changed 9 years ago by onlyjob

Thank you for your relentless effort and time -- much appreciated.

comment:4 Changed 8 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/183

Note: See TracTickets for help on using tickets.