xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 9 years ago

Closed 9 years ago

Last modified 6 months ago

#188 closed defect (fixed)

Double-click required for single-clicks to register on remote attachments

Reported by: alphapapa Owned by: Antoine Martin
Priority: major Milestone: 0.7
Component: core Version: 0.0.7.36
Keywords: Cc:

Description

I am really enjoying xpra! Thank you for making it.

I don't have any trouble when I'm attached to a local xpra server, but when I connect to a remote one, I have to double-click for single-clicks to register. Right-clicking works fine.

Change History (10)

comment:1 Changed 9 years ago by Antoine Martin

Status: newaccepted

Please provide details, are you really using v0.0.7.36? If so, please upgrade to the latest release.

If not, please tell us (full version info): your local desktop environment, operating system at both ends, type of connection, what commands you run, does this happen if you use a different machine/desktop/version?
Is there anything suspicious in the logfiles?

comment:2 Changed 9 years ago by Antoine Martin

Also, you talk about "remote attachments" in the title of the bug - this is presumably in some application that you use? Which one? Is this the only place where this occurs? If so, a screenshot of the exact location would be great (to help me reproduce it reliably).

comment:3 Changed 9 years ago by Antoine Martin

(reply obtained via email)
I'm running Ubuntu Precise at both ends. The app in question is
Clementine.
I haven't checked any logs - does xpra write any by default?
Do I need to build xpra myself or can I hunt down a deb?
I'm not at my computer right now or I'd google around. And by "remote
attachments" I meant when I attach to a remote xpra instance over my
LAN via ssh, as opposed to attaching to a local instance.

comment:4 Changed 9 years ago by Antoine Martin

Yes, the xpra server does create a log file when you start it, it tells you about it too.
The client does not, although you can increase verbosity by adding "-d all" to the command line.
But in your case, this would not be particularly helpful I don't think.

You have not specified what version of xpra you are using.. so I still do not know..

There are fresh new builds in the beta repo (built today):
http://xpra.org/beta/

Otherwise, use the standard builds:
Ubuntu Precise Repo

comment:5 Changed 9 years ago by alphapapa

I installed 0.6.3 but haven't tested it remotely yet. I see 0.6.4 is in the repo now. I'll install it and let you know what I find out.

comment:6 Changed 9 years ago by Antoine Martin

0.7.0 is in the repos now.

comment:7 Changed 9 years ago by Antoine Martin

Also note that whether the app is on a remote system or a local one makes absolutely no difference, so there must be something else at play. Have you tried using a different desktop environment?
Shot in the dark, are you using KDE?

comment:8 Changed 9 years ago by cookacounty

If you are using KDE, this is from the winswitch faq
http://winswitch.org/documentation/faq.html

I Use KDE and I can't click in windows, they move instead
That's because of a bug/feature in KDE. To work around it, execute oxygen-settings and change WidgetStyle?->Windows drag mode to Drag windows from titlebar only. This can only be fixed permanently in KDE.

I was sucessful after making this change.

comment:9 Changed 9 years ago by Antoine Martin

Resolution: fixed
Status: acceptedclosed

OK closing, thanks.

Note this is also covered in the xpra faq

(hopefully ubuntu will pickup the KDE fix in quantal.. we have had the magic KDE workaround token since r773, about 6 months ago)

comment:10 Changed 6 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/188

Note: See TracTickets for help on using tickets.