xpra icon
Bug tracker and wiki

Opened 4 weeks ago

Closed 4 weeks ago

#1890 closed defect (fixed)

fedora 27 epoch madness

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 2.4
Component: packaging Version: 2.3.x
Keywords: Cc:

Description

For whatever reason (ffmpeg apparently), the Fedora 27 package of xpra uses an epoch.
See Use of Epochs.

And once again, we're left to pick up the pieces of this mess.

I tried adding an epoch to our package: r19730, but now dnf just gets confused working out the dependencies, complaining that the packages we tell it to install and conflicting, with themselves, or something. What a mess.

Change History (1)

comment:1 Changed 4 weeks ago by Antoine Martin

Resolution: fixed
Status: newclosed

It looks like the Epoch tag applies to all the sub-packages within the same specfile, so we have to add the epoch to the versioned dependencies too, done in r19747.

Backport in r19748 + build no bumped in r19749. 2.3.2-4 fixes this mess.

And now we have to remember to undo this mess once Fedora 27 goes EOL.
Fortunately this madness never landed in the Fedora 28 specfile - not sure how distro upgrades are going to handle this though.. What an epic clusterfsck.

Note: See TracTickets for help on using tickets.