xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 3 years ago

Closed 3 years ago

Last modified 4 months ago

#1940 closed defect (fixed)

Starting a session over SSH causes duplicate start children

Reported by: J. Max Mena Owned by: Antoine Martin
Priority: minor Milestone:
Component: core Version: trunk
Keywords: Cc:

Description

I found this one while following up on #1920 and #1646:

Starting a session via SSH by running xpra start ssh:user@host --start-new-commands=yes --start=xterm causes two Xterms to appear. Starting a session with xpra start ssh:vorfuehreffekt --start-new-commands=no --start=xterm does not cause the duplication - only one Xterm window appears for the session.

The issue seems to be limited to --start-new-commands=yes, and it's a minor issue at that.

I'm not sure what logs to get - I have -d all piped into a .log file but I'm not sure how much use that will be. Reproducing is very easy, simply start with:

xpra start ssh:user@host --start-new-commands=yes --start=xterm and you'll see two Xterms pop up.

Change History (3)

comment:1 Changed 3 years ago by Antoine Martin

Status: newassigned

Odd, the server command line actually used looks fine:

$ xpra info | grep server.argv
server.argv=('/usr/bin/xpra', 'start', '--start=xterm', '--start-new-commands=yes', \
    '--env=XPRA_PROXY_START_UUID=41a73c090ea64db6b540d0ad89f105cc', \
    '--daemon=yes', '--systemd-run=no', '--displayfd=5', \
    '--start-via-proxy=no')

(with system proxy turned off)

comment:2 Changed 3 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Doh, this is caused by r20046 for #1931.
Fixed in r20211.

comment:3 Changed 4 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1940

Note: See TracTickets for help on using tickets.