xpra icon
Bug tracker and wiki

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#1971 closed defect (fixed)

copy to clipboard on server -> empty on client

Reported by: michael Owned by: Antoine Martin
Priority: critical Milestone: 2.4
Component: clipboard Version: 2.3.x
Keywords: Cc:

Description

Hello...

Ubuntu Server 16.04 Xpra 2.3.4-r20525-1
Windows 7 Client

Clipboard directions: Both

Clipboard from Client (copy) -> Server (paste):

works

Clipboard from Server (copy) -> Client (paste):

it depends:

Xpra-x86_64_Setup_2.4-r20553.exe: works
Xpra-Client_Setup_2.3.4-r20511.exe: fails
Xpra-Client_Setup_2.3.4-r20510.exe: fails
Xpra-Client-x86_64_Setup_2.3.3-r20115.exe: works

"fails" means: The clipboard on Windows is empty after copying something on the server.

Reproducible.

We use 2.3.3 and will upgrade to 2.4 if the clipboard works in the final 2.4 release.

Kind regards
Michael

Change History (3)

comment:1 Changed 2 years ago by Antoine Martin

Priority: majorcritical
Status: newassigned

All the clipboard changes for 2.3.x are here: log/xpra/tags/v2.3.x/src/xpra/clipboard.
The only change in the 2.3.4 release is r20414.

This is a backport from the 2.4 branch and only triggers when we detect invalid clipboard data. (the bug should therefore also affect 2.4)

comment:2 Changed 2 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Turns out that the bug is not in the clipboard code, it's a bug in the system tray image code which is triggered whenever we send or receive a clipboard packet.

The bug was caused by the "patch" command making a mess of a backport in r20372 (yet again..), then I tried to fix it up by hand in r20510, and missed some bits.

This is now fixed correctly in r20589. (and backported clipboard sanitization code in r20590)

I am still investigating a clipboard related hang with MS Windows clients, this one affects both 2.4 and 2.3.

@michael: there is an updated 2.3.4 installer with this fix here: https://xpra.org/beta/windows/

comment:3 Changed 2 years ago by michael

2.3.4 Beta works - thanks!

Note: See TracTickets for help on using tickets.