xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 3 years ago

Closed 3 years ago

Last modified 9 months ago

#2156 closed enhancement (wontfix)

detect network pushback

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 2.5
Component: network Version: 2.4.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Following #999, the idea here was to use non-blocking sockets and catch EINTR then use this event to detect when the OS is blocking on writes.

The problem is that python3 actually retries syscalls automatically on EINTR so that's a non-starter.

See:

There may be other socket options we can use on Linux: socket man page but this won't be portable.

Change History (3)

comment:1 Changed 3 years ago by Antoine Martin

Description: modified (diff)
Resolution: wontfix
Status: newclosed

The only way to do this would be to use native OS calls for the network layer.

comment:2 Changed 21 months ago by Antoine Martin

For Linux, TCP_INFO: #2421.

comment:3 Changed 9 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2156

Note: See TracTickets for help on using tickets.