xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 2 years ago

Closed 2 years ago

Last modified 5 months ago

#2206 closed defect (duplicate)

Mouse capture doesn't work that well

Reported by: Michael van der Gulik Owned by: Antoine Martin
Priority: minor Milestone: 2.4
Component: android Version: 2.4.x
Keywords: mouse Cc:

Description

Example: install the simple game "assaultcube", which is a "small" 40MB demo I found which is suitable for testing and is available in the Debian / Ubuntu repos. You'll find that this and similar first-person shooters don't work well with xpra (v2.4.3-r21365).

In assaultcube, you spend most of your time looking at either the ceiling or floor. The behaviour of the mouse is very different than when the game is run locally.

In Minecraft, you start looking straight ahead, but then get stuck staring at the floor when you move the mouse.

minetest just failed to open a window. Not sure why. I haven't investigated.

Using shift+menu successfully locks the mouse to the window, but doesn't stop you staring at the floor.

Change History (3)

comment:1 Changed 2 years ago by Antoine Martin

Resolution: duplicate
Status: newclosed

Have you tried using uinput for input devices?
This looks like an exact duplicate of #137.

comment:2 Changed 16 months ago by Antoine Martin

Milestone: future2.4

comment:3 Changed 5 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2206

Note: See TracTickets for help on using tickets.