xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Changes between Initial Version and Version 1 of Ticket #221


Ignore:
Timestamp:
12/07/12 02:25:18 (9 years ago)
Author:
Antoine Martin
Comment:

Fixed in r2196 Sorry, was meant to commit this yesterday.. (will need to backport to 0.7.x too)

FYI: this is reproducible simply by closing a window which is getting a lot of redraws, the client will often be able to destroy the window before the last draw event is received

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #221

    • Property Status changed from new to closed
    • Property Resolution changed from to fixed
  • Ticket #221 – Description

    initial v1  
    11I get these sometimes:
    22
     3{{{
    342012-12-06 15:56:29,327 error processing draw packet
    45Traceback (most recent call last):
     
    1819    assert self._main_thread==threading.currentThread(), "queuing should only be called from the main thread!"
    1920AssertionError: queuing should only be called from the main thread!
     21}}}
    2022
    2123The problem was quite reproducible before I patched my Xpra as described in ticket #220, so I think it might actually not be the problem of the draw_thread_loop to begin with.
     
    2729With '-d all' I get this log:
    2830
    29 -- snip --
     31{{{
    30322012-12-06 16:13:27,749 process_draw 1 bytes for window 111 using mmap encoding with options={}
    31332012-12-06 16:13:27,749 draw_region(775, 316, 93, 30, mmap, 1 bytes, 280, {}, [<function record_decode_time at 0x267cc80>, <function after_draw_refresh at 0x267cb90>])
     
    8991    assert self._main_thread==threading.currentThread(), "queuing should only be called from the main thread!"
    9092AssertionError: queuing should only be called from the main thread!
    91 -- snap --
     93}}}
    9294
    9395FWIW this is all done using a couple of patches on top of r2180, but only touching src/{setup.py,xpra.README,xpra/server.py} (where the patch to server.py is the one attached to ticket #220).