Xpra: Ticket #2236: when try accessing html5 client, it kept redirected to connect.html page for authentication

I have tried couple time to access the html5 client by pointing my local browser to access my vm server by trying the instruction from wiki/Clients/HTML5. The index.html page showed the scene of websocket connection´╝î but after a while it rediect to the connect.html for authentication. After that happen a couple of times, I fellow the instruction of the Password Authentication section and it did not work at all.

PS: I ran the testing host where the xpra got installed within the VMware player from my local mechine.

Any info will be helpful.



Sat, 23 Mar 2019 16:42:31 GMT - Antoine Martin: owner, description changed

The html5 client should work out of the box on all supported distributions. It is impossible to help you without more details, see wiki/ReportingBugs.


Wed, 27 Mar 2019 01:36:48 GMT - jia chen: status changed; keywords, resolution set

Finally got it working. The reason for the connection failure is that the rule of firewall under CentOS is not allowing any other ports than 14500 to listen from outside. To resolve this issue, you just need to do the following command:

# firwwall-cmd --permanent --add-port=<port-number>/tcp && firewall-cmd --reload

These will get you access to the port which you have just setup.


Sat, 23 Jan 2021 05:45:49 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2236