xpra icon
Bug tracker and wiki

Opened 10 months ago

Closed 10 months ago

Last modified 6 months ago

#2372 closed defect (fixed)

macos opengl window resizing corruption

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: blocker Milestone: 3.0
Component: client Version: 2.5.x
Keywords: Cc:

Description

Could be related to #2217, #1497 or #478.

Change History (3)

comment:1 Changed 10 months ago by Antoine Martin

Status: newassigned

See also #1794

comment:2 Changed 10 months ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Fixed in r23441.

This is only enabled by default on macos, since the corruption is only visible there, but it can be enabled on other platforms using XPRA_OPENGL_CONTEXT_REINIT=1.

This bypasses the smooth resizing (#478 and #2217)

comment:3 Changed 6 months ago by Antoine Martin

Caused a regression: #2491.

Note: See TracTickets for help on using tickets.