xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 17 months ago

Closed 17 months ago

Last modified 5 weeks ago

#2431 closed defect (fixed)

AES regression

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: blocker Milestone: 4.0
Component: network Version: 3.0.x
Keywords: Cc:

Description

Caused by r21542, found using bisection.

Clients now fail to connect:

Warning: AES decryption failed: invalid padding
Error: AES encryption padding error - wrong key?

Affects both python2 and python3 builds.

Change History (3)

comment:1 Changed 17 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

Fixed in r24022.

comment:2 Changed 9 months ago by Antoine Martin

Same problem with legacy mode: ticket:2793#comment:8.

comment:3 Changed 5 weeks ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2431

Note: See TracTickets for help on using tickets.