Xpra: Ticket #2490: Cannot spin up a HTML mode

xpra start :10 --start-child=xeyes --bind-tcp= --html=on --no-daemon

At first I was getting

2019-11-22 10:37:13,840 cannot create group socket '/run/xpra/netikras-PC-10'
2019-11-22 10:37:13,840  [Errno 13] Permission denied
2019-11-22 10:37:13,891 pointer device emulation using XTest

I ran sudo chmod o+w /run/xpra to get around this. Not sure if I did it right, but I no longer see the Permission Denied error.

But I'm still getting an error below when trying to either do xdg-open or attach via https://xpra.org/html5/connect.html .

2019-11-22 10:51:08,744 pointer device emulation using XTest
2019-11-22 10:51:08,797 Error: cannot find the html web root
2019-11-22 10:51:08,797  '/usr/share/xpra/www' does not exist
2019-11-22 10:51:09,541 OpenGL is supported on display ':10'
2019-11-22 10:51:19,831 Error: tcp connection failed:
2019-11-22 10:51:19,832  packet from
2019-11-22 10:51:19,832  received on
2019-11-22 10:51:19,832  invalid packet header, HTTP GET request

Attaching a full log.

Am I doing something wrong?

xpra --version: xpra v4.0-r24461
pip show websockify | grep -i vers
Version: 0.9.0

Fri, 22 Nov 2019 09:07:26 GMT - netikras: attachment set

xpra log

Fri, 22 Nov 2019 09:10:38 GMT - Antoine Martin: owner changed

cannot create group socket

See wiki/FAQ

Error: cannot find the html web root
 '/usr/share/xpra/www' does not exist

Which xpra package did you install? This directory must exist, that is the html5 client.

pip show websockify | grep -i vers

Websockify is not required or used by xpra since v2.4: #2121.

Mon, 16 Dec 2019 20:38:00 GMT - netikras: status changed; resolution set

Thanks Antoine for the hint!

though I feel stupid now :) All I needed it the obvious thing: apt install xpra-html5. Somehow I was under impression that the html5 client comes OOTB with the xpra package. After reading wiki/Clients/HTML5 I did not even think I'd need to install smth else :)

Anyways, my bad. Thanks again! I'm very glad you folks are doing this project. It's exactly what I've been looking for for a while now. TA!

Tue, 17 Dec 2019 04:28:27 GMT - Antoine Martin:

Somehow I was under impression that the html5 client comes OOTB with the xpra package

It is a Recommends dependency of the main xpra package. So you must have used --no-install-recommends when you installed xpra.

I have updated the wiki page: wiki/Clients/HTML5 (removed websockify, etc)

Thu, 06 Feb 2020 09:09:00 GMT - Antoine Martin: component, description, milestone changed

Note for those hitting the same error but not using the official xpra packages: most distributions packages should NOT be used and they often miss crucial functionality, such as the HTML5 client.

Sat, 23 Jan 2021 05:52:43 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2490