xpra icon
Bug tracker and wiki

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#2569 closed defect (fixed)

macOS: _imaging.so requires version 11.0.0 or later, but libtiff.5.dylib provides version 10.0.0

Reported by: mjlbach Owned by: Antoine Martin
Priority: minor Milestone: 4.0
Component: client Version: 4.0.x
Keywords: Cc:

Description

2020-01-31 09:51:36,863 Error: failed to load overlay icon '/Applications/Xpra.app/Contents/Resources/share/xpra/icons/xpra.png':
Traceback (most recent call last):
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/client/mixins/window_manager.py", line 223, in init
    from PIL import Image   #@UnresolvedImport
  File "<frozen zipimport>", line 259, in load_module
  File "PIL/Image.pyc", line 90, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "PIL/_imaging.pyc", line 14, in <module>
  File "PIL/_imaging.pyc", line 10, in __load
  File "imp.pyc", line 342, in load_dynamic
ImportError: dlopen(/Applications/Xpra.app/Contents/Resources/lib/python/lib-dynload/PIL/_imaging.so, 2): Library not loaded: @executable_path/../Frameworks/libtiff.5.dylib
  Referenced from: /Applications/Xpra.app/Contents/Resources/lib/python/lib-dynload/PIL/_imaging.so
  Reason: Incompatible library version: _imaging.so requires version 11.0.0 or later, but libtiff.5.dylib provides version 10.0.0
2020-01-31 09:51:36,865  dlopen(/Applications/Xpra.app/Contents/Resources/lib/python/lib-dynload/PIL/_imaging.so, 2): Library not loaded: @executable_path/../Frameworks/libtiff.5.dylib

Change History (4)

comment:1 Changed 4 months ago by Antoine Martin

Status: newassigned

@mjlbach: what version is this?

comment:2 Changed 4 months ago by mjlbach

This was on the latest server/client beta 4.0.x

comment:3 Changed 4 months ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Thank you for reporting this bug!

The problem was caused by some changes in jhbuild: the libtiff library had been upgraded to v4.1 by mistake, normally a rebuild fixes things, but the new jhbuild caches things in places that even its own clean command doesn't actually clean... Removing those manually then rebuilding python-pillow ensures that the correct library version is used.

You can find updated beta 3.0.6 and 4.0 builds here: https://xpra.org/beta/MacOS.

comment:4 Changed 4 months ago by mjlbach

You're welcome, and thank you for the quick solution!

Note: See TracTickets for help on using tickets.