xpra icon
Bug tracker and wiki

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#2584 closed defect (invalid)

TIMESTAMP expansion not happening

Reported by: stdedos Owned by: Antoine Martin
Priority: trivial Milestone: 4.0
Component: server Version: 3.0.x
Keywords: Cc:

Description

The feature from r24348 seems to not work

u@h:/run/user/1000/xpra$ xpra start gnome-terminal
xpra for python 2.7 is not installed
 retrying with python3
Entering daemon mode; any further errors will be reported to:
  /run/user/1000/xpra/display-gnome-terminal-$TIMESTAMP.log
u@h:/run/user/1000/xpra$ ls -lah
total 16K
drwx------  2 u u   80 Φεβ  10 15:47 .
drwx------ 14 u u  420 Φεβ  10 15:31 ..
-rw-r--r--  1 u u 5,2K Φεβ  10 15:47 display-gnome-terminal-$TIMESTAMP.log
-rwx------  1 u u 5,7K Φεβ  10 15:47 run-xpra

And its lines seem non-existent

/usr/lib/python3/dist-packages/xpra $ grep TIMESTAMP scripts/server.py
/usr/lib/python3/dist-packages/xpra $ 

Change History (2)

comment:1 Changed 4 months ago by Antoine Martin

Resolution: invalid
Status: newclosed
$ grep TIMESTAMP xpra/scripts/server.py
    extra_expand = {"TIMESTAMP" : datetime.datetime.now().strftime("%Y%m%d-%H%M%S")}

My guess is that your server is not running v4.

This is not a bug fix so it has not been included in the 3.0.x branch, though it is scheduled for 3.1: milestone/3.1.

comment:2 Changed 4 months ago by stdedos

Oh ... I keep forgetting that it was targeted for v4.

Oh well :/

Note: See TracTickets for help on using tickets.