xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 13 months ago

Closed 10 months ago

Last modified 3 months ago

#2710 closed defect (fixed)

win32 shadow server slow to exit

Reported by: totaamwin32 Owned by: Antoine Martin
Priority: major Milestone: 4.1
Component: platforms Version: 3.0.x
Keywords: Cc:

Description

Sending it a stop request, it prints Shutting down in response to client request reasonably quickly, but then there's a 5 second delay until we call clean_quit.
Looks like the UI thread is too busy, probably somewhere in cleanup_protocols? flush_then_close?

Change History (2)

comment:1 Changed 10 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

It was caused by mdns_updated, added in r22709.

We now use the background worker to avoid the delays: r26886.

comment:2 Changed 3 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2710

Note: See TracTickets for help on using tickets.