xpra icon
Bug tracker and wiki

Opened 6 months ago

Closed 3 weeks ago

Last modified 6 days ago

#2747 closed defect (worksforme)

Seamless windows do not re-attach maximized

Reported by: stdedos Owned by: stdedos
Priority: minor Milestone: 4.1
Component: client Version: 3.0.x
Keywords: Cc:

Description

Has anything change between r26124 and r26160?

Nowadays, when I am attaching previously maximized windows, appear with the same size, at non-maximized state, with a +20,+20 pixel (towards top,right)

Attachments (2)

Xpra-2747_cmd_2020-07-13_10-18-12.png (21.9 KB) - added by stdedos 4 months ago.
Xpra-2747_cmd_2020-07-13_10-39-52.png (54.4 KB) - added by stdedos 4 months ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 6 months ago by stdedos

Summary: Seamless windows do not start maximizedSeamless windows do not re-attach maximized

comment:2 Changed 6 months ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos

Has anything change between r26124 and r26160?

Lots of things: r26124 to r26160.
But nothing that should change the behaviour of maximized windows.

Is this a mswindows client?
I cannot reproduce with an xterm, what do I need to do?

Last edited 4 months ago by Antoine Martin (previous) (diff)

comment:3 Changed 6 months ago by stdedos

Yes, Win10 Client. Roughly this setup:

Xpra-Python3-x86_64_4.0-r26124\xpra_cmd" shadow ssh://user@ip/0 --ssh="plink -ssh -agent" --opengl=no --bandwidth-limit=10Mbps --desktop-scaling=0.75 --min-speed=70 --webcam=no --speaker=off --microphone=off --pulseaudio=no

2020-04-23 10:22:50,479 Xpra GTK3 client version 4.0-r26124 64-bit
2020-04-23 10:22:50,482  running on Microsoft Windows 10
2020-04-23 10:22:51,726 GStreamer version 1.16.2 for Python 3.8.2 64-bit
2020-04-23 10:22:52,129 keyboard layout code 0x409
2020-04-23 10:22:52,129 identified as 'United States - English' : us
2020-04-23 10:22:52,629  keyboard settings: layout=us
2020-04-23 10:22:52,635  desktop size is 4160x1440 with 1 screen:
2020-04-23 10:22:52,636   Default (1100x381 mm - DPI: 96x96) workarea: 4160x1400
2020-04-23 10:22:52,636     Generic PnP Monitor 1600x900 at 0x534 (309x174 mm - DPI: 131x131) workarea: 1600x860
2020-04-23 10:22:52,636     C32JG5x 2560x1440 at 1600x0 (697x392 mm - DPI: 93x93) workarea: 2560x1400
2020-04-23 10:22:52,637  downscaled to 75%, virtual screen size: 5547x1920
2020-04-23 10:22:52,637   Default (1100x381 mm - DPI: 128x128) workarea: 5547x1867
2020-04-23 10:22:52,637     Generic PnP Monitor 2133x1200 at 0x712 (309x174 mm - DPI: 175x175) workarea: 2133x1147
2020-04-23 10:22:52,637     C32JG5x 3413x1920 at 2133x0 (697x392 mm - DPI: 124x124) workarea: 3413x1867
2020-04-23 10:23:14,977 enabled remote logging
2020-04-23 10:23:14,979 Xpra GTK3 shadow server version 3.0.9-r26132 64-bit
2020-04-23 10:23:14,981  running on Linux Ubuntu 16.04 xenial
2020-04-23 10:23:14,983  remote desktop size is 6400x1440

I use two screens. Usually all my windows are maximized in one monitor or the other.
When I am done working, I shut laptop's lid.
Next morning, I am powering it up, connecting etc.

At that point, it used to be that all server windows (around 10 or something) came as they were. Nowadays, they come at a +20-top,+20-right px offset. (I don't remember what was the case like today).

comment:4 Changed 6 months ago by Antoine Martin

Milestone: 4.04.1

The ticket says: Seamless windows do not re-attach maximized, but your command is a shadow. Which one is it?
I am confused.

comment:5 Changed 6 months ago by stdedos

No, I just copied the first recent command line I found - for the purposes of filling server/client/configuration. It is unfortunate that it was a shadow connection.

comment:6 Changed 4 months ago by Antoine Martin

This could be a multi-monitor issue (again), because this works fine here with a single monitor in virtualbox.
Does this happen with a simple application, like an xterm? (which is not actually that simple since xterm has size constraints..)
Can you try the latest builds? And if the window is not how it should be, post the window information (from the new headerbar menu, or using a client socket as per ticket:2744#comment:1)

comment:7 Changed 4 months ago by stdedos

Even on my side, it happens once every "when it doesn't feel like it".

My client is on 4.0.2, as headerbar is the last straw of annoying to work around with - if you would start backporting the small features, I could try with the shortcut method of opening the window you are mentioning.

comment:8 Changed 4 months ago by stdedos

Owner: changed from stdedos to Antoine Martin

set "XPRA_EXECUTABLE=Xpra-Python3-x86_64_4.1-r26947"

"Xpra-Python3-x86_64_4.1-r26947\xpra_cmd" attach ssh://user@ip/2 --ssh="plink -ssh -agent" --modal-windows=no --title="@title@ on @@/@server-display@" --opengl=no --bandwidth-limit=6Mbps

2020-07-13 10:14:29,277 Xpra GTK3 client version 4.1-r26947 64-bit
2020-07-13 10:14:29,279  running on Microsoft Windows 10
2020-07-13 10:14:31,580 GStreamer version 1.16.2 for Python 3.8.3 64-bit
2020-07-13 10:14:32,101 keyboard layout code 0x409
2020-07-13 10:14:32,102 identified as 'United States - English' : us
2020-07-13 10:14:32,448  keyboard settings: layout=us
2020-07-13 10:14:32,452  desktop size is 4160x1440 with 1 screen:
2020-07-13 10:14:32,454   Default (1100x381 mm - DPI: 96x96) workarea: 4160x1400
2020-07-13 10:14:32,454     Generic PnP Monitor 1600x900 at 0x534 (309x174 mm - DPI: 131x131) workarea: 1600x860 at 0x534
2020-07-13 10:14:32,456     C32JG5x 2560x1440 at 1600x0 (697x392 mm - DPI: 93x93) workarea: 2560x1400 at 1600x0
2020-07-13 10:15:11,309 enabled remote logging
2020-07-13 10:15:11,312 Xpra GTK3 X11 server version 3.0.10-r26630 64-bit
2020-07-13 10:15:11,314  running on Linux Ubuntu 16.04 xenial
2020-07-13 10:15:11,330  (press Control-C to detach)


(xpra_cmd:16464): Pango-WARNING **: 10:15:12.139: couldn't load font "Bitstream Vera Sans Not-Rotated 14.662109375", falling back to "Sans Not-Rotated 14.662109375", expect ugly output.
2020-07-13 10:15:13,164 UI thread is now blocked
2020-07-13 10:15:13,478 UI thread is running again, resuming
2020-07-13 10:15:13,509 Warning: static gravity is not handled

For the gray window (attached maximized on + offset):

Attached:

wid=122
title= on @/:2
override-redirect=False
state=maximized
attributes=
focused=False
buttons=none
gravity=NorthWest
content-type=unknown
pixel-depth=24
alpha=False
opengl=False
geometry=2560x1359 at 1626,105
outer-geometry=2560x1359 at 1626,64
inner-geometry=2560x1359 at 1626,105
offsets=none
frame-extents=8, 8, 31, 8
max-size=32767, 32767
size-constraints=position : (1654, 0)
size=2560, 1359
render-size=2560, 1359
backing-offsets=0, 0, 0, 0

vs Maximized

wid=122
title=on @/:2
override-redirect=False
state=maximized
attributes=
focused=False
buttons=none
gravity=NorthWest
content-type=unknown
pixel-depth=24
alpha=False
opengl=False
geometry=2560x1359 at 1626,64
outer-geometry=2560x1359 at 1600,0
inner-geometry=2560x1359 at 1600,41
offsets=none
frame-extents=8, 8, 31, 8
max-size=32767, 32767
size-constraints=position : (1654, 0)
size=2560, 1359
render-size=2560, 1359
backing-offsets=0, 0, 0, 0


For the purple window (attached maximized with transparent bars left, down):

Attached:

wid=65
title=pythonProject – test_main.py on @/:2
override-redirect=False
state=maximized
attributes=
focused=False
buttons=none
gravity=NorthWest
content-type=unknown
pixel-depth=24
alpha=False
opengl=False
geometry=2508x1307 at 1626,64
outer-geometry=2560x1359 at 1600,0
inner-geometry=2560x1359 at 1600,41
offsets=none
frame-extents=8, 8, 31, 8
max-size=32767, 32767
size-constraints=position : (2611, 173)
minimum-size : (340, 0)
size=2508, 1307
render-size=2508, 1307
backing-offsets=0, 0, 0,

vs Maximized

wid=65
title=pythonProject – test_main.py on @/:2
override-redirect=False
state=maximized
attributes=
focused=False
buttons=none
gravity=NorthWest
content-type=unknown
pixel-depth=24
alpha=False
opengl=False
geometry=2560x1359 at 1626,64
outer-geometry=2560x1359 at 1600,0
inner-geometry=2560x1359 at 1600,41
offsets=none
frame-extents=8, 8, 31, 8
max-size=32767, 32767
size-constraints=position : (2611, 173)
minimum-size : (340, 0)
size=2560, 1359
render-size=2560, 1359
backing-offsets=0, 0, 0,


Last edited 4 months ago by stdedos (previous) (diff)

Changed 4 months ago by stdedos

comment:9 Changed 4 months ago by Antoine Martin

Owner: changed from Antoine Martin to stdedos

content-type=unknown

What application is running?
We should add a content-type mapping for it, especially since it looks like it should be text.
Does the problem go away if you use --header-bar=no ?

Changed 4 months ago by stdedos

comment:10 Changed 4 months ago by stdedos

Jetbrains Dev Tools (PyCharm, RubyMine, Android Studio ... https://www.jetbrains.com/toolbox-app/, mouse-hover on "Tools" header section)

It has had happened in the pre-headerbar times (r26124), so I wouldn't dismiss it so quickly.

I am taking r26947 /w headerbar for a spin at this time - let's see if I'll disable it or not.

Last edited 4 months ago by stdedos (previous) (diff)

comment:11 Changed 4 months ago by stdedos

This reminds me of #2762 in part.

comment:12 Changed 4 months ago by stdedos

Note that the non-window transparent space of attachment/ticket/2747/Xpra-2747_cmd_2020-07-13_10-39-52.png is click-through.

Last edited 3 months ago by Antoine Martin (previous) (diff)

comment:13 Changed 3 weeks ago by Antoine Martin

Resolution: worksforme
Status: newclosed

Cannot reproduce with pycharm or android studio.
Tested with Fedora and MSWindows clients.

comment:14 Changed 6 days ago by stdedos

I keep seeing this with increased frequency (i.e. 2 every 10 re-attachments).

xpra looses connectivity (at the end of the day) with all applications maximized; When I re-attach (the next day), they re-attach as not-maximized.

What more diagnostics can I get you to check this one?

Note: See TracTickets for help on using tickets.