xpra icon
Bug tracker and wiki

Opened 6 weeks ago

Closed 12 days ago

#2819 closed defect (worksforme)

Shift key

Reported by: Dušan Vejnovič Owned by: Dušan Vejnovič
Priority: major Milestone: 4.1
Component: keyboard Version: 4.0.x
Keywords: Cc:

Description (last modified by Antoine Martin)

I'm running the xpra server v4.0.2-r26625-1 on Debian 10.
In LibreOffice Writer I can't mark text for copying with the shift key and the arrow right key. In version 3.0.10-r26630-2 this option works normally: with the combination of shift key and arrow right key I can mark the text to be copied.

Change History (8)

comment:1 in reply to:  description Changed 6 weeks ago by Dušan Vejnovič

Running LibreOffice version 6.1.5-3+deb10u6.

Last edited 6 weeks ago by Antoine Martin (previous) (diff)

comment:2 Changed 6 weeks ago by Dušan Vejnovič

Component: androidkeyboard

comment:3 Changed 6 weeks ago by Antoine Martin

Status: newassigned

What is the client OS and version? Also 4.0.2 on Debian 10?

comment:4 Changed 6 weeks ago by Dušan Vejnovič

Yes. Same OS, OS version (Debian 10) and Xpra version (4.02) on the server and on the client.

comment:5 Changed 6 weeks ago by Antoine Martin

Description: modified (diff)

What is your keyboard layout and configuration?
(see hints in wiki/Keyboard)
Does your client display use wayland?

comment:6 Changed 6 weeks ago by Dušan Vejnovič

I'm using Slovenian keyboard layout, nothing special, system configured (Xfce desktop). And my client display not use wayland.

comment:7 Changed 6 weeks ago by Antoine Martin

Owner: changed from Antoine Martin to Dušan Vejnovič
Status: assignednew

I am assuming that this is what your server log shows:

setting keyboard layout to 'si'

I've tested with a gnome session on wayland and also on x11, with libreoffice and with gedit.
In all cases I was able to use shift + arrows to select text.
All tested on Debian 10.4

So please try a gnome session to see if the problem is somehow specific to your xfce desktop.
If not, then there's some other detail that you are not reporting.

As per comment:5, see wiki/Keyboard.

comment:8 Changed 12 days ago by Antoine Martin

Resolution: worksforme
Status: newclosed

Not heard back.

Note: See TracTickets for help on using tickets.