xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.

Opened 22 months ago

Closed 21 months ago

Last modified 17 months ago

#2869 closed defect (needinfo)

client drawing problem after xpra upgrade on server

Reported by: MJ Owned by: MJ
Priority: critical Milestone: 4.1
Component: server Version: 4.0.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Reproducible 100% with Terminator app (and likely many others)
Server: Linux FC31, xpra v4.0.2-r26625
Client: Windows 10, Xpra GTK3 client version 4.0.3-r27086 64-bit

After server machine reboot and starting new xpra session from client context menu windows (right click on terminator panel) are drawn correctly.

When xpra upgrade is run on server and the client reattached, context menus are no longer drawn nor clickable. The only redrawn part of the window is its shadow win win64 client.

Steps to repro

  1. Server: machine reboot and xpra service starts automatically
  2. Client:
     .\Xpra_cmd.exe start --quality=100 --speaker=off --ssh='wsl ssh' ssh/mjd/123 --start=terminator --opengl=no

Terminator window shows up on client

  1. Verification point: Right click on terminator window to show context menu:

menu shown OK

  1. Server:
    $ xpra upgrade :123
    Failed to create bus connection: No such file or directory
    [mj@mj-opti7040 ~]$ Entering daemon mode; any further errors will be reported to:
    Actual log file name is now: /run/user/3035/xpra/:123.log

Client session gets disconnected as expected

  1. reattach client session


 .\Xpra_cmd.exe attach --quality=100 --speaker=off --ssh='wsl ssh' ssh/mjd/123 --start=terminator --opengl=no

Terminator windows shows up on client

  1. Right click on terminator window:

context menu does not show up.
Only shadow visible over other application if it would hover there.
Clicking in shadowed area does not produce action.

Repeating above steps with omission of step 4 does not reproduce the problem.

Attachments (2)

xpra-bad.png (125.2 KB) - added by MJ 22 months ago.
xpra client showing only shadow of context menu
xpra-ok.PNG (92.4 KB) - added by MJ 22 months ago.
xpra showing context menu before upgrade

Download all attachments as: .zip

Change History (6)

Changed 22 months ago by MJ

Attachment: xpra-bad.png added

xpra client showing only shadow of context menu

Changed 22 months ago by MJ

Attachment: xpra-ok.PNG added

xpra showing context menu before upgrade

comment:1 Changed 22 months ago by Antoine Martin

Description: modified (diff)
Priority: majorcritical
Status: newassigned

comment:2 Changed 21 months ago by Antoine Martin

Owner: changed from Antoine Martin to MJ
Status: assignednew

I cannot reproduce with a Fedora 31 server.
I've tried running 4.0.4 and also latest trunk (4.1 beta).

For the client, I've tried with the same versions locally (easier) and then with an MS Windows client - again, with 4.0.4 and 4.1 beta.

I thought that maybe I needed to have the popup window shown when I issue the xpra upgrade to trigger the bug, but that makes no difference.

@mafjmafj: what am I missing?
Can you try with the latest versions?
Maybe simplify your commands and just use TCP. And try with a Fedora client.

comment:3 Changed 21 months ago by Antoine Martin

Resolution: needinfo
Status: newclosed

comment:4 Changed 17 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2869

Note: See TracTickets for help on using tickets.