xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 7 months ago

Closed 6 months ago

Last modified 6 months ago

#2997 closed defect (fixed)

Xpra 4.0.6 fails to run on Windows

Reported by: markus Owned by: markus
Priority: major Milestone: 4.1
Component: core Version: 4.0.x
Keywords: Windows Cc:

Description (last modified by Antoine Martin)

After installing xpra, the current version 4.0.6 fails to start and outputs the error shown in the screenshot.
Python error when launching xpra

The error kept the same on a clean Windows 10 VM.

The error does not appear on older version. I tested the following versions on the Win 10 VM:

  • Xpra-Client-Python3-x86_64_Setup_4.0.3-r27086 = ok
  • Xpra-Client-Python3-x86_64_Setup_4.0.5-r27999 = ok
  • Xpra-Client-Python3-x86_64_Setup_4.0.5-r28002 = ok

Attachments (1)

error.png (54.9 KB) - added by markus 7 months ago.
Python error when launching xpra

Download all attachments as: .zip

Change History (6)

Changed 7 months ago by markus

Attachment: error.png added

Python error when launching xpra

comment:1 Changed 7 months ago by Antoine Martin

Description: modified (diff)
Status: newassigned

Probably due to the recent breakage in cx_Freeze : #2994, as the packaging has bot been modified since 4.0.5

I noticed that some of the window icons are also missing..

comment:2 Changed 6 months ago by Antoine Martin

Milestone: 4.24.1
Owner: changed from Antoine Martin to markus
Status: assignednew

I have re-issued the 4.0.6 builds using an even older version (6.1) of cx_Freeze for packaging, this seems to work for me.

The missing window header bar icons were caused by another cx_Freeze "feature" it seems, r28334 works around that one.

There are now some r28334 builds in the download area, with some minor extra fixes included as a bonus.

Please close if this works for you.

comment:3 Changed 6 months ago by Antoine Martin

Make that r28335.

For the record, I don't understand why we need so many ugly workarounds for what seems like a simple job.. or why the development branch does not seem to be affected.

Examples: #2846, #1857, #2631, #2611, etc..

Last edited 6 months ago by Antoine Martin (previous) (diff)

comment:4 Changed 6 months ago by markus

Resolution: fixed
Status: newclosed

Thank you for your fast response.
I just tested r28335, and the client-only (https://xpra.org/dists/windows/Xpra-Client-Python3-x86_64_Setup_4.0.6-r28335.exe) as well as the "normal" version (https://xpra.org/dists/windows/Xpra-x86_64_Setup.exe) are now working for me.

comment:5 Changed 6 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2997

Note: See TracTickets for help on using tickets.