xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 8 years ago

Closed 8 years ago

Last modified 8 months ago

#337 closed defect (invalid)

0.9.2: stop do not terminate X server

Reported by: onlyjob Owned by: onlyjob
Priority: major Milestone:
Component: server Version: 0.9.x
Keywords: Cc:

Description

In 9.0.2 xpra stop :13 leaves corresponding X server running.
Process "/usr/bin/Xorg-for-Xpra-:13" is still active and I can't "xpra start :13" on that display again without "--use-display".

Earlier versions were terminating associated X server on xpra stop.

Change History (5)

comment:1 Changed 8 years ago by Antoine Martin

Status: newassigned

comment:2 Changed 8 years ago by Antoine Martin

Owner: changed from Antoine Martin to onlyjob
Status: assignednew

Hmmm, I cannot reproduce with r3391 or with 0.9.x, here is the server log when I issue xpra stop (with or without a client connected makes no difference):

Python/GObject Linux client version 0.10.0 connected from 'dhcppc17'
windows/pixels forwarding is disabled for this client
max client resolution is 0x0 (from []), current server resolution is 4800x1200
Shutting down in response to request
Tray.cleanup()
Disconnecting existing client Protocol(SocketConnection(/home/antoine/.xpra/dhcppc17-10)), reason is: shutting down
connection closed after 2 packets received (565 bytes) and 2 packets sent (1032 bytes)
xpra client disconnected.
Connection lost
Connection lost
New connection received: SocketConnection(/home/antoine/.xpra/dhcppc17-10)
connection closed after 0 packets received (0 bytes) and 0 packets sent (0 bytes)
Connection lost
xpra is terminating.
removing socket /home/antoine/.xpra/dhcppc17-10
killing xvfb with pid 28122
xterm: fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server ":10"
Server terminated successfully (0). Closing log file.

TILs:

Shutting down in response to request
(..)
killing xvfb with pid 28122

comment:3 Changed 8 years ago by onlyjob

Thanks for checking...

Strangely enough I can't reproduce this issue again after terminating "Xorg-for-Xpra-:13" that was left after "xpra stop" when I logged this ticket...

"Xorg-for-Xpra-:13" was started when I was testing patch for #335. I'm not sure how it's all happened but apparently somehow it failed to terminate on "xpra stop"....

Perhaps we can close this issue for now until there will be reliable information how to reproduce...

comment:4 Changed 8 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

OK, feel free to re-open, preferably if you have reproducible steps.

comment:5 Changed 8 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/337

Note: See TracTickets for help on using tickets.