xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#347 closed defect (duplicate)

xpra: PDFs appear very tiny in evince under xpra at 100% zoom

Reported by: Timo Juhani Lindfors Owned by: Antoine Martin
Priority: major Milestone: 0.10
Component: server Version: 0.9.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Copied from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=709008

Package: xpra
Version: 0.9.2+dfsg-1
Severity: normal

Steps to reproduce:

Expected results:

  • text is readable

Actual results:

  • text is way too tiny to be read.

This does not occur without xpra so I guess it is doing something that
confuses evince about the size of the screen. Please reassign to
evince if you believe that the bug is not in xpra.

This did not occur with xpra 0.3.4+dfsg-1

This does not seem to occur if I use

xpra start --no-daemon --xvfb 'Xvfb +extension Composite -screen 0 3840x2560x24+32 -nolisten tcp -noreset  -auth $XAUTHORITY' :14

so maybe this is somehow related to Xdummy?

"man xpra" still claims that the default value of --xvfb would be

'Xvfb +extension Composite -screen 0 3840x2560x24+32 -nolisten tcp -noreset  -auth $XAUTHORITY'

but this is apparently not the case anymore?

-- System Information:

Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=C, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages xpra depends on:
ii  libavcodec53              6:0.8.6-1
ii  libc6                     2.17-2
ii  libswscale2               6:0.8.6-1
ii  libvpx1                   1.1.0-1
ii  libwebp2                  0.1.3-3+nmu1
ii  libx11-6                  2:1.5.0-1
ii  libx264-123               2:0.123.2189+git35cf912-1
ii  python                    2.7.3-5
ii  python-gtk2               2.24.0-3+b1
ii  python-wimpiggy           0.9.2+dfsg-1
ii  x11-xserver-utils         7.7~3
ii  xserver-xorg-input-void   1:1.4.0-1+b1
ii  xserver-xorg-video-dummy  1:0.3.5-2+b1

Versions of packages xpra recommends:
ii  openssh-client  1:6.2p1-3
ii  python-imaging  1.1.7-4
ii  ssh-askpass     1:1.2.4.1-9

Versions of packages xpra suggests:
ii  gstreamer0.10-plugins-bad   0.10.23-7.1
ii  gstreamer0.10-plugins-good  0.10.31-3+nmu1
ii  gstreamer0.10-plugins-ugly  0.10.19-2+b2
pn  openssh-server              <none>
pn  pulseaudio                  <none>
pn  pulseaudio-utils            <none>
ii  python-dbus                 1.2.0-1
pn  python-gst0.10              <none>
pn  python-gtkglext1            <none>

-- no debconf information

Change History (4)

comment:1 Changed 7 years ago by Antoine Martin

Component: clientserver
Description: modified (diff)
Milestone: 0.10
Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

comment:2 Changed 7 years ago by Antoine Martin

Resolution: duplicate
Status: assignedclosed

Please see ticket:163#comment:19 and see if removing "-dpi 96" helps.

comment:3 Changed 7 years ago by Timo Juhani Lindfors

Hmm, I didn't notice that you had commented on the bug since I did not get any email about it. I now tried verifying my email address again, let's hope that fixes it.

Anyways, if I use

xpra start --no-daemon \
   --xvfb '/usr/bin/Xorg -noreset -nolisten tcp +extension GLX \
       +extension RANDR +extension RENDER -logfile /home/lindi/.xpra/Xorg.:14.log \
      -config /etc/xpra/xorg.conf :14' \
   :14

then the document is readable but the menu and toolbar text is huge.

Last edited 7 years ago by Antoine Martin (previous) (diff)

comment:4 Changed 7 years ago by Timo Juhani Lindfors

Testing xpra.org bug tracker, please ignore this and sorry for the noise...

Note: See TracTickets for help on using tickets.