xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 8 years ago

Closed 8 years ago

Last modified 5 weeks ago

#369 closed defect (fixed)

mouse cursor is too big

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 0.10
Component: core Version:
Keywords: Cc:

Description (last modified by Antoine Martin)

Although this may well be related to #189 ("Mouse cursor is tiny"), this deserves a new ticket.

Other related tickets:

  • #163 "pass client DPI preference to server (and use sane defaults of 96dpi)"
  • #343 "huge mouse cursor on text selection"

It looks like a race, so please provide steps to help reproduce it and the cursor related output from "xpra info".

It would also be useful to launch a new xterm from the xterm with the misbehaving cursor to see if the new one still has the same problems.

Other useful info:

  • dpi info from xpdyinfo and xrdb (see #163)
  • get_default_cursor_size value (see #343)

Change History (3)

comment:1 Changed 8 years ago by Antoine Martin

Description: modified (diff)
Resolution: fixed
Status: newclosed

Never mind, I assumed the code in #189 had been reverted from trunk already because:

  • I normally always commit to trunk for testing before committing to another branch - but in this case, it was a revert so I didn't...
  • I've seen this bug intermittently (or so I thought)

Fixed in r3770, feel free to re-open if not.

comment:2 Changed 8 years ago by alas

It looks like the cursor on the initial xterm is still a hair on the large side... or maybe I've been staring at too many xterm cursors and I'm hallucinating.

Since it's not enough of a difference for me to be sure it's not just a hallucination, I'll leave the ticket closed.

comment:3 Changed 5 weeks ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/369

Note: See TracTickets for help on using tickets.