xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#482 closed defect (fixed)

No handlers could be found for logger "xpra.scripts.config"

Reported by: Norman Rasmussen Owned by: Antoine Martin
Priority: major Milestone:
Component: client Version: 0.10.x
Keywords: Cc:

Description

This warning message has been appearing on startup since 0.10.10.

Change History (5)

comment:1 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to Norman Rasmussen

Please specify your distro, version, xpra package version, etc.
I am not seeing this on win32 or Fedora.

Please also attach your /etc/xpra/xpra.conf (and .xpra/xpra.conf if you have one).

comment:2 Changed 6 years ago by Norman Rasmussen

This is on Ubuntu Precise after upgrading from 0.10.9-1 to 0.10.10-1.

I can reproduce with just "xpra" or "xpra --version".

The only change to that file during between the two versions is r4827, perhaps when ffmpeg2 is not installed it generates the message?

Last edited 6 years ago by Antoine Martin (previous) (diff)

comment:3 Changed 6 years ago by Norman Rasmussen

Owner: changed from Norman Rasmussen to Antoine Martin

assigning back to you to confirm, feel free to re-assign to antoine as required.

comment:4 Changed 6 years ago by Antoine Martin

Status: newassigned

You are right, this is caused by r4827 and it is specific to 0.10: in 0.11, we initialize the codecs later, after the logging system.
The easiest solution will be to remove dec_avcodec from the build, you can just remove it form your installation to get rid of the warning.

comment:5 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Fixed in r5142, will be included in 0.10.11 - feel free to re-open if I've missed anything.

Note: See TracTickets for help on using tickets.