xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#484 closed defect (fixed)

client right-click drop menus require button be held

Reported by: alas Owned by: alas
Priority: major Milestone: 0.11
Component: client Version:
Keywords: Cc:

Description

Using osx client 0.11.0 r4998 with fedora 19 server 0.11.0 r5066 with a chrome browser - when right clicking on links or highlighted text, the drop menu appears for a fraction of a second, then closes by default "choosing" the top menu item.

If the right mouse button is held depressed, however, the menu persists (as long as the button is held), allowing the choice of other options than the topmost.

WIth an osx chrome browser running locally right clicking links or highlighted text creates a pop-up drop menu which persists until an option is chosen, or focus is shifted off the menu.

(Even just links and highlighting text on youtube will demonstrate this.)

Attachments (1)

Screen Shot 2014-01-07 at 5.25.15 PM.png (55.3 KB) - added by alas 5 years ago.
left-click with osx client on facebook drop menu

Download all attachments as: .zip

Change History (9)

comment:1 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas

I am seeing the same problem with win32 and Linux clients.
Is osx relevant? How does it make any difference?

There is a now a very simple test case added in r5112: browser/xpra/trunk/src/tests/xpra/test_apps/test_context_menu.py (just right click in the text input area)

Then I also came across this: Eclipse right-click issue with X11 forwarding

Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 5 years ago by Antoine Martin

If, unless I am missing something, this isn't related to osx, please edit the ticket title.

If r5113 fixes the issue (works fine for me with gedit, the example from comment:1 and chrome), then you can also close the ticket. (I may backport this to 0.10.x if I make another stable release)

comment:3 Changed 5 years ago by Antoine Martin

Milestone: 0.120.11

(changing milestone to current since this looks fixed)

comment:4 Changed 5 years ago by alas

I thought it was OS independent, but when I double-checked before posting the bug, it seemed to be behaving with windows.

When I tested with updated (r5144) clients but a still old xpra server though, the issue was indeed OS independent (both misbehaved in the same way).

Testing with an updated server as well, I find that win client behaves as expected, both right and left clicking drop menus.

With an osx client the right click works as expected as well, but a left click on a drop down menu (the drop down birth date month, day and year menus on facebook, specifically) - the menu pops up and persists, but appears "behind" the window... while nevertheless retaining focus (I was able to click drop menu options I couldn't see because they were obscured by the facebook window itself).

I'll attach a screenshot to, hopefully, make this explanation less confusing.

Changed 5 years ago by alas

left-click with osx client on facebook drop menu

comment:5 Changed 5 years ago by Antoine Martin

Summary: osx client right-click drop menus require button be heldclient right-click drop menus require button be held

This fix was included in 0.10.11 as r5138

Is the new issue "left click drop down menu lack of focus" a regression? A result of this change, or an existing bug? (please use a new ticket if this is not a regression)
Does it happen when selecting the drop down using the keyboard instead of the mouse?
Does it also happen with this test application: xpra/test_apps/test_drop_down.py. Does it happen with any other applications that use drop downs menus?

Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:6 Changed 5 years ago by alas

Testing back as far as 0.11.0 r4755 with the osx client, it looks like this is not a regression after all.

  • Left clicking on drop down menus in an xpra session window which does not have focus - the drop down menu works as expected.
  • Left clicking on drop down menus in an xpra session window which does have focus - the drop down menu appears "behind" the window (though the drop menu can be clicked "through" the window which "appears" to have focus).
  • Left clicking on drop down menus in an xpra session window, when the menu itself has focus - the drop down menu works as expected.
  • Using the keyboard to tab to the menu and select it - works as expected. (Presumably this method brings focus to the menu item before "clicking" it, thus working as the instance above.)

I will try to use the test application when I get a chance for full test. I could also test some 0.10 clients if you think it might help (I'll try a couple spot tests when time permits).

comment:7 Changed 5 years ago by Antoine Martin

OK, so this is not a regression and not related to this ticket client right-click drop menus require button be held.

Please close this ticket and file a new ticket for this new issue, including details from comment:6, preferably including screenshots for each case as it is quite likely that our ideas of "focus" are different.
There are at least two focus concepts: which window has focus (and since we have a client and as server, each end maintains its own copy - and yes, they may get out of sync, that's why we have so many focus tickets), and the widget focus (within the currently focused window).
See also the test application from comment:5 which is a lot easier to test with than a full blown application.
Also note that when testing for regressions, testing another release from the same branch (v0.11.x) does not guarantee that this is not a regression, only that this is not a recent regression. Testing with 0.10.x and earlier is much more telling.

Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:8 Changed 5 years ago by alas

Resolution: fixed
Status: newclosed

Right-click menu issues are fixed. Left-click menu issues have their own ticket now (#490).

Closing.

Note: See TracTickets for help on using tickets.