xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#630 closed defect (fixed)

Client crash when clipboard has data

Reported by: Smo Owned by: Smo
Priority: critical Milestone: 0.14
Component: client Version: trunk
Keywords: Cc:

Description

Win32 client revision 7189
Fedora 20 server revision 7189

client crash when clipboard has data

2014-08-07 16:15:01,315 internal error: error in network packet write/format
Traceback (most recent call last):
  File "xpra\net\protocol.pyc", line 253, in _write_format_thread_loop
  File "xpra\net\protocol.pyc", line 263, in _add_packet_to_queue
  File "xpra\net\protocol.pyc", line 420, in encode
  File "xpra\client\gtk2\client.pyc", line 249, in compress_clipboard
  File "xpra\client\gtk2\client.pyc", line 297, in compressed_wrapper
  File "xpra\net\compression.pyc", line 186, in compressed_wrapper
  File "xpra\net\compression.pyc", line 26, in lz4_compress
TypeError: must be string or read-only buffer, not list
2014-08-07 16:15:01,316 Connection lost

Change History (3)

comment:1 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to Smo
Priority: majorcritical

I am unable to reproduce the problem, I guess you must have some specific clipboard data type to trigger this, which I do not have.

This makes me very uncomfortable because I cannot confirm whether the fix in r7196 does resolve this problem. Please also be aware that we no longer even attempt to compress strings smaller than 512 bytes, which means that what used to crash this code before may not crash it any more but that this alone does not necessarily mean that the actual bug is fixed.

As always, please include -d clipboard in bug reports about clipboard.

comment:2 Changed 6 years ago by alas

Testing with windows 0.14.0r7205 against fedora 20 0.14.0r7189 ... I am also unable to reproduce the problem.

Smo got a crash copying some urls. I was copying entire web pages ... 14 KB, 22 KB, 35 KB - with no problems at all. I was also able to copy urls without incident.

You may be able to close this ticket: I can continue to check and re-open if the problem re-emerges.

comment:3 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

OK thanks, closing and hoping for the best!

Note: See TracTickets for help on using tickets.