xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#631 closed defect (fixed)

H.265 encoding: windows not redrawn

Reported by: Szunti Owned by: Szunti
Priority: minor Milestone: 0.14
Component: encodings Version: trunk
Keywords: Cc:

Description

Tried emacs and thunderbird and most of the window is not redrawn unless I move the mouse. Other encodings are fine.

Change History (3)

comment:1 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to Szunti

Have you tried x264 and/or vp8? Are you testing trunk or 0.13?

If trunk, this could be an undesired side effect of the changes I just made in #620.

Otherwise, it may just be a bug with x265... which rarely ever gets tested because it is so slow. See wiki/Encodings.

comment:2 Changed 6 years ago by Szunti

I tried both x264 and vp8, and they were ok. I used revision [7202]. It's just before your latest code in #620. I don't really care for x265. I just thought it's better to open a ticket.

comment:3 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Hah, thanks. In r7207 I've made it clearer that h265 and vp9 should not be used, removing them from the tray menu.

But then I thought that this might change in the future if and when the encoding libraries improve, so r7208 lets the server tell the client which encodings should be avoided (since the problem is encoding side).

I will probably leave it as it is for 0.13.x. Closing.

Note: See TracTickets for help on using tickets.