xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#681 closed defect (fixed)

tray icon breaks xpra attach on gnome 3.12

Reported by: pyther Owned by: pyther
Priority: minor Milestone:
Component: client Version: 0.14.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Operating System: Fedora 20
Xpra 0.14.6

This error does not occur on ArchLinux with Xpra 0.14.6.

$ ssh attach ssh:pyther@host.example.com:301
2014-09-14 11:35:30,023 xpra client version 0.14.6
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
2014-09-14 11:35:30,324 OpenGL_accelerate module loaded
2014-09-14 11:35:30,324 Using accelerated ArrayDatatype
2014-09-14 11:35:30,325 OpenGL support could not be enabled:
2014-09-14 11:35:30,325  The texture size is too small: 8192
2014-09-14 11:35:30,498 detected keyboard: rules=evdev, model=pc104, layout=us
2014-09-14 11:35:30,499 desktop size is 5680x1440 with 1 screen(s):
2014-09-14 11:35:30,499   ':0.0' (1503x381 mm) workarea: 5680x1413 at 0x27
2014-09-14 11:35:30,499     eDP1 2560x1440 (310x174 mm)
2014-09-14 11:35:30,499     DP3 1680x1050 at 2560x0 (474x296 mm)
2014-09-14 11:35:30,499     DP4 1440x900 at 4240x0 (408x255 mm)
****************************************************************************
                          NOTICE TO USERS
****************************************************************************
Error in atexit._run_exitfuncs:
Traceback (most recent call last):
  File "/usr/lib64/python2.6/atexit.py", line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "/usr/lib64/python2.6/logging/__init__.py", line 1516, in shutdown
    h.flush()
  File "/usr/lib64/python2.6/logging/__init__.py", line 762, in flush
    self.stream.flush()
ValueError: I/O operation on closed file
Error in sys.exitfunc:
Traceback (most recent call last):
  File "/usr/lib64/python2.6/atexit.py", line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "/usr/lib64/python2.6/logging/__init__.py", line 1516, in shutdown
    h.flush()
  File "/usr/lib64/python2.6/logging/__init__.py", line 762, in flush
    self.stream.flush()
ValueError: I/O operation on closed file
2014-09-14 11:36:39,523 The SSH process has terminated with exit code 0
2014-09-14 11:36:39,524 Connection to the xpra server via SSH failed for: ssh:pyther@host.example.com:301
2014-09-14 11:36:39,524  the command line used was: ['ssh', '-l', 'pyther', '-T', 'host.example.com', 'xpra initenv >> /dev/null 2>&1 || echo "Warning: xpra server does not support initenv" 1>&2;~/.xpra/run-xpra _proxy :301']
2014-09-14 11:36:39,525  check your username, hostname, display number, etc
2014-09-14 11:36:39,525 internal error: read connection TwoFileConnection(ssh:pyther@host.example.com:301) closed: cannot read using ['ssh', '-l', 'pyther', '-T', 'host.example.com', 'xpra initenv >> /dev/null 2>&1 || echo "Warning: xpra server does not support initenv" 1>&2;~/.xpra/run-xpra _proxy :301']: the SSH process has terminated with exit code=0

Change History (11)

comment:1 Changed 6 years ago by pyther

Summary: xpra fails to attach on fedora20 ValueErrortray icon breaks xpra attach on gnome 3.12

This appears to be an issue with the tray icon. Running with --no-tray allows xpra to start without a problem.

Running Fedora 20 with Gnome 3.12. I have not followed gnome development but in 3.12 you can right click on system tray icon (from the message center) and it gives you the right click menu. I don't think this was the cause with older versions of gnome.

comment:2 Changed 6 years ago by pyther

I think #657 might be related. Also found this Debian mailing list which seems to describe the same issue. https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1250201.html

comment:3 Changed 6 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to pyther

I am unable to reproduce this with a clean Fedora 20 virtual machine, or with my local dev box. (or with Debian as per #657)

Can you please try to give me something easier to reproduce or at least narrow it down a bit: is SSH required for reproducing the bug? does this happen if you connect locally? (no ssh or tcp) if not, does it happen using TCP mode?
Does it occur with an Arch client? Arch server? Or just Fedora clients with any server type?
What about ssh to localhost?
Does it happen everytime, or most of the time? etc..

comment:4 Changed 6 years ago by pyther

I believe this is an issue with gnome 3.12. I am using gnome 3.12 on Fedora 20 from the rhughes f20-gnome-3-12 copr repository [1].

I do not use gnome on Arch, but I suspect the problem would be reproducible if I did.

The problem is always reproducible. It occurs when attaching to a local and a remote server. It also occurs when using TCP or SSH. From what I can tell this is certainly a client issue and is unrelated to the version running on the server.

Running with '--no-tray' always allows xpra to work.

(1) https://copr.fedoraproject.org/coprs/rhughes/f20-gnome-3-12/

Last edited 6 years ago by pyther (previous) (diff)

comment:5 Changed 6 years ago by Antoine Martin

Owner: changed from pyther to Antoine Martin
Priority: majorminor
Status: newassigned

I quote: It contains packages built automatically that have had very little testing.

I'm not saying there isn't a bug in xpra... but at this point, I can't spend too much time installing unstable bits to cause problems, I've got enough problems already!

I'll test when I get a chance.

comment:6 Changed 6 years ago by Antoine Martin

Confirmed in a VM with gnome 3.12 from the repo above.

Interesting (and annoying) data point: whilst still running the old gnome with the new libraries installed, xpra still worked ok (xpra was running against the libraries then..).
Which means that the problem is likely to be gnome-side, and much harder to figure out.

comment:7 Changed 6 years ago by Antoine Martin

Got something interesting: --delay-tray also fixes things.

I think it has something to do with us creating the tray widget before the main loop is running.

comment:8 Changed 6 years ago by Antoine Martin

Fixed in r7641. Will backport.

@pyther: does that fix things for you?

comment:9 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to pyther
Status: assignednew

comment:10 Changed 6 years ago by pyther

Applied the patch on top of 0.14.6, it solves the problem. Thanks!

comment:11 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Backport in r7653. Closing.

Note: See TracTickets for help on using tickets.