xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#690 closed defect (fixed)

OSX Application Menu display "python" rather than "Xpra"

Reported by: alas Owned by: Antoine Martin
Priority: minor Milestone:
Component: client Version: 0.14.x
Keywords: Cc:

Description

It is a cosmetic detail, but a slightly annoying one. The application menu of the OSX clients (trunk, 0.14.7, etc.) displays as python rather than Xpra.

Likewise, inside the menu, options like Hide python and Quit python are displayed, rather than referring to Xpra.

Attachments (1)

ticket-690_OSX-0.14.7_python-application-menu.png (68.6 KB) - added by alas 6 years ago.
OSX application menu displays python instead of Xpra (0.14.x and trunk)

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by alas

OSX application menu displays python instead of Xpra (0.14.x and trunk)

comment:1 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas

Inlining the image:
OSX application menu displays python instead of Xpra (0.14.x and trunk)

Well, that's annoying. I can reproduce with 10.6 onwards, but not with 10.5 - which is what I had used for developing and most of the testing.
Please always include the full details of the OS used for testing (version, etc) - and try more than one if possible.
I believe it's been like this since r7065 (almost 2 months).

I didn't want to go back to the old code which duplicated the wrapper script many times over, so we go back to duplicating, but we duplicate the "python" binary via the build script instead.

Done in r7756, tested on 10.5 and 10.6. Does that work for you?

Last edited 6 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 6 years ago by alas

Owner: changed from alas to Antoine Martin

Testing with r7797 - works splendidly.

Ready to be closed (after a back porting).

comment:3 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Backport in r7805. Closing.

Note: See TracTickets for help on using tickets.