xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#693 closed defect (fixed)

scaling rendering is broken with opengl

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: blocker Milestone: 0.15
Component: client Version: trunk
Keywords: Cc:

Description

Not sure when this started, tested with vpx. (found thanks to #692)

The opengl window renders the update only on the top-left portion of the screen which corresponds to the downscaled dimensions.
The non-opengl rendering works fine.

Change History (2)

comment:1 Changed 6 years ago by Antoine Martin

Good news: v0.14.x is not affected by this, but trunk r7803 is.

Bisecting by visual inspection (..) using a server running like this:

XPRA_SCALING_HARDCODED=1:3 xpra start :10 --start-child=glxspheres --no-mmap

Hardcoding the scaling to ensure it is enabled, and disabling mmap which bypasses encodings.

So this was caused by #679.

comment:2 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Fixed in r7804: we must paint the screen using the unscaled dimensions!

Note: See TracTickets for help on using tickets.