xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

#696 closed defect (wontfix)

Client memory leak if Win32 client 0.14+ runs inside a RDP session

Reported by: Antoine Martin Owned by: sschnitzer
Priority: minor Milestone: 0.15
Component: platforms Version: trunk
Keywords: win32 Cc: sschnitzer@…

Description

Split from ticket:684#comment:10.

Change History (8)

comment:1 Changed 3 years ago by Antoine Martin

Cc: sschnitzer@… added
Owner: changed from Antoine Martin to sschnitzer

I cannot reproduce, I've tried an XP 32 bit client and a Windows 7 64 bit client. I've tried turning opengl off, sound on and off, changing encodings, etc..

Please provide more details.
Maybe also try the latest windows beta build to see if it helps. (some of the earlier beta builds had a broken opengl initializations, which would have caused it to revert to cairo / GTK rendering)

comment:2 Changed 3 years ago by Antoine Martin

More info on this was added to #684

comment:3 Changed 3 years ago by sschnitzer

This is a follow up to the question on #684.
I tried to evaluated if memory consumption growth depends on the encoding. Unfortunately, I currently can only log in remotely via RDP to the Windows machine. It seems that the RDP connection significantly impacts this evaluation. I will continue trying to get some reasonable results on that, which might take a few weeks.
Can the ticket stay open that long?
Is there anything else I can do?

comment:4 Changed 3 years ago by Antoine Martin

No problem with keeping this ticket open a bit longer. If the leak only ever happens with RDP.. chances are that this is part of the problem.

Once you have more info, please edit this ticket title to better reflect the cause of the problem: is the use of a proxy server required or not? RDP required? Encodings? Sound? opengl? etc.

comment:5 Changed 3 years ago by Antoine Martin

Any update? Should this be a blocker for 0.15?

Last edited 3 years ago by Antoine Martin (previous) (diff)

comment:6 Changed 3 years ago by sschnitzer

Summary: memory leak in win32 0.15 beta clientClient memory leak if Win32 client 0.14+ runs inside a RDP session

I did some further tests, observations follow.
a) encoding=rgb did not have any noticeable effect on the leak.
b) It definitely only occurs if the xpra client is executed within a RDP session. If I reconnect to a crashed session on a native Windows 7, the leak doesn't occur any more. My setup: Xpra-Server with Xpra-Proxy on Centos-7 <-> Windows-7 RDP-Server <-> Win7-RDP-Client or xfreerdp on Linux.
c) I reproduced this with 0.14.10 client and server and also with Windows client r8235 and Linux server r8249.

comment:7 Changed 3 years ago by Antoine Martin

Priority: criticalminor

Have you tried turning opengl off? Does re-connecting via RDP change anything, etc..

Lowering the priority because it looks like a bug in RDP or windows. I've also added links in the FAQ: wiki/FAQ

comment:8 Changed 3 years ago by Antoine Martin

Resolution: wontfix
Status: newclosed

Not heard back, closing. Feel free to reopen if you can reproduce without RDP and with our latest builds. Otherwise... I doubt there's much we can do.

Note: See TracTickets for help on using tickets.