xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#748 closed defect (fixed)

--start-child leaves zombie

Reported by: Lukas Haase Owned by: Lukas Haase
Priority: critical Milestone:
Component: server Version: 0.14.x
Keywords: start-child, zombie Cc:

Description

The current stable (xpra v0.14.12) I am using with CentOS leaves zombies behind if a process is started with --with-child and exits. This is reproduceable for me.

Example:

xpra start :1900 --no-daemon --session-name=MATLAB --no-mdns --start-child=/usr/bin/xterm --exit-with-children

Then I connect/attach to this instance and enter "exit" in xterm. xterm teminates but not xpra. Closer inspection reveals that xterm is a zombie:

$ ps aux | grep -i xterm
user 28978  0.0  0.0      0     0 pts/4    Z+   13:53   0:00 [xterm] <defunct>
user 29164  0.0  0.0   6392   680 pts/5    S+   13:55   0:00 grep -i xterm


I did not find any tickets related to it.

Change History (6)

comment:1 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

I've just tested on Fedora 20 and I'm not seeing the problem.
Could be because you're on python 2.6, and we have to use a different codepath (polling) in the child reaper for that python version.

Another (much less likely since the xterm shows as a zombie) possibility is if you have other start-child options in your /etc/xpra/xpra.conf or in your .xpra/xpra.conf.

I'll try to test next week on my centos vms.

comment:2 Changed 6 years ago by Lukas Haase

It's not the second option - no start-child options in the config files.

Seems most likely that the polling does not work

comment:3 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to Lukas Haase
Status: assignednew

Should be fixed in r8183, can you confirm and I will backport to v0.14.x?

comment:4 Changed 6 years ago by Antoine Martin

Backport in r8185 - would be good if someone could confirm I haven't broken anything before I make the next stable release..

comment:5 Changed 6 years ago by Lukas Haase

Thank you! What is the best way to try it out temporarily in CentOS 6?
Using the winswitch beta repository temporarily and switching back or manually installing the xpra rpm and trying to get rid of it afterwards?

comment:6 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

This was included in 0.14.13 so I am closing this ticket, feel free to re-open if I've missed anything.


What is the best way to try it out temporarily in CentOS 6?
Using the winswitch beta repository temporarily and switching back or manually installing the xpra rpm and trying to get rid of it afterwards?


The beta repository is an add-on, it may not have all the packages from the main repository. Usually, downloading and installing the one or two RPM that you need by hand does the job, otherwise temporarily adding the beta repository can also do the job... as long as you remember to disable it afterwards.

Note: See TracTickets for help on using tickets.